Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying very hard to compile the minimal document in this example. I just want to use CJK on my Windows install of Miktex and it always fails with this message:

miktex-makemf: The udmj source file could not be found.
Running hbf2gf.exe...

hbf2gf (CJK ver. 4.8.0)

Couldn't find `udmj.cfg'
miktex-maketfm: No creation rule for font udmj67.

! Font C70/min/m/n/10/67=udmj67 at 10.0pt not loadable: Metric (TFM) file not f
ound.
<to be read again>
                   relax
l.7 \begin{CJK}{UTF8}{min}未
                             t+¦pü¬püŵòúpééµí£pü»püòpüÅpéësôë\end{CJK} \\
?

Any ideas on how to fix this?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

There are some problem with MiKTeX's cjk-fonts package. Unicode Japanese fonts for wadalab are missing.

In MiKTeX now, you can only use C42 and C52 font encoding for wadalab fonts, say, use

\begin{CJK}{JISdnp}{min}

or

\begin{CJK}{JIS2dnp}{min}

with proper input encoding will work. It is really not enough, I think.


An alternative is to use xeCJK with XeLaTeX. For example,

% UTF-8 Encoding, compile with XeLaTeX
\documentclass{article}
\usepackage{xeCJK}
\setCJKmainfont{MS Mincho} % for \rmfamily
\begin{document}
おはよう
\end{document}
share|improve this answer
    
already did that –  Nate Glenn Sep 20 '11 at 14:13
    
@Nate: Then try to refresh FNDB (font name database) in MiKTeX Options. It seems that there are some problem with your installation. –  Leo Liu Sep 20 '11 at 14:31
    
did that, still nothing. I've never had installation problems of any sort before... –  Nate Glenn Sep 20 '11 at 14:40
    
@Nate: Hmm... I use TeX Live. After checking on MiKTeX, I'm sure that in MiKTeX wadalab fonts are not complete. This is a BUG of MiKTeX. I think you can contact Christian Schenk for this problem. Anyway, there are other ways to use Japanese in TeX, see also my previous answer. –  Leo Liu Sep 20 '11 at 14:52
    
@Leo, @Nate Yes this is a bug in miktex. Nate sent a minimal example to the mailing list and for this example the complete "virtual font" layer (tfm in udmj + vf) from mincho-0-12-20080306.tar.gz are missing. The example works fine after I installed the missing file. Probably other fonts from wadalab are incomplete too. I will make a bug report. –  Ulrike Fischer Sep 21 '11 at 7:42
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.