Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem with the tex memory while using pgfplots and a very huge dataset in Ubuntu. Under Windows with MikTeX I have the following settings and the texfile compile without any problems:

main_memory=250000000   

extra_mem_top=50000000

extra_mem_bot=50000000  

save_size=15000

stack_size=15000

In Ubuntu 11.04 with TexLive i set the tex memory settings according to the pgfplots-manual.

1) i create a texmf.cnf in the directory: /home/user/System/mytexcnf

2) content of texmf.cnf is listed above.

3) run "sudo texhash"

4) create environment variable with: export TEXMFCNF=~/System/texmf/mytexcnf:

Running my texfile gives errors and here is the text from the logfile:

Here is how much of TeX's memory you used:
18954 strings out of 494950
443204 string characters out of 3177351
3000001 words of memory out of 3000000
21827 multiletter control sequences out of 15000+200000
5432 words of font info for 20 fonts, out of 3000000 for 9000
36 hyphenation exceptions out of 8191
65i,13n,78p,2482b,1740s stack positions out of 5000i,500n,10000p,200000b,50000s

Did i something wrong by setting the tex memory? How can i see from the logfile the needed values for the memory parameters? How can i change the texmf.cnf later? Only by opening in an editor, change the values, saving and run texhash?

share|improve this question

closed as too localized by egreg, Marco Daniel, Stefan Kottwitz Feb 4 '12 at 21:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
1  
Check step 4: there's a texmf part that shouldn't be there. Also "sudo texhash" is not necessary. You'll probably have to rebuild your formats with fmtutil. –  egreg Sep 20 '11 at 15:05
    
Did you rebuild the format files after changing the settings? This is required. –  Martin Scharrer Sep 20 '11 at 15:06
    
i thougt texhash rebuild the format files. how do i rebuild the format files? –  Mac-Cherony Sep 20 '11 at 15:31
    
sorry, i overread the fmtutil , but running fmtutil -- refresh don't work. i become still the memory error –  Mac-Cherony Sep 20 '11 at 15:38

Browse other questions tagged or ask your own question.