Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm running a pretty hacked-up template for my thesis, and the bibliography chapter's title is now too high. (This is due to various changes to the 'normal' chapter titles and their alignment/spacing, changes that I'd like to keep.)

So essentially I'd like to add in a \vspace{3.3cm} before the "References" title. How can I do this? (Using BibTeX and \bibliographystyle{ieeetr}, if it makes any difference. The normal "Bibliography" title has been changed to "References".)

Bonus if I can re-align it too back to the left.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It looks like you're using BibTeX, right? Either way, I think you need to do a \renewcommand on the thebibliography environment, probably along the following lines of the code below (to be inserted in your document's preamble).

Do note that the example assumes you're using the book or the report documentclass (or one that's derived from them); if you use the article documentclass, you'll need to replace the command \chapter* with \section* (one occurrence). I've gone ahead and inserted the required name of the bibliography, viz. "References".

\makeatletter 
\renewcommand{\@biblabel}{} %% to suppress the numeric labels (only if needed)
\renewenvironment{thebibliography}[1]
     %% If using article documentclass, replace 
     %% "\chapter*` with "\section*" below
     {\chapter*{References}%   
      \phantom{a}\vspace{3.3cm}
      \@mkboth{References}{References}%
      \list{\@biblabel{\@arabic\c@enumiv}}%
           {\settowidth\labelwidth{\@biblabel{#1}}%
            \leftmargin\labelwidth
            \advance\leftmargin\labelsep
            \@openbib@code
            \usecounter{enumiv}%
            \let\p@enumiv\@empty
            \renewcommand\theenumiv{\@arabic\c@enumiv}}%
      \sloppy
      \clubpenalty4000
      \@clubpenalty \clubpenalty
      \widowpenalty4000%
      \sfcode`\.\@m}
     {\def\@noitemerr
       {\@latex@warning{Empty `thebibliography' environment}}%
      \endlist}
\makeatother

Separately, I'm not sure what you mean by "Bonus if I can re-align it too back to the left." If you mean that you don't want an indent of entries after the first line, try issuing the command \renewcommand{\bibindent}{0pt}. If you mean that you want to suppress the [.] numeric labels, you'd have to issue the command \renewcommand{\@biblabel}{}, best immediately after the \makeatletter instruction. Or, do you mean you want the text to be left-justified (as opposed to "fully justified")? If so, just issue the command \raggedright before starting the bibliography. Better yet, load the ragged2e package in the preamble and then issue the command \RaggedRight. The latter command is preferable because it doesn't suppress hyphenation.

share|improve this answer
    
Thank you for the quick reply Mico. I tried to implement the code and got the following error: ! LaTeX Error: Command \thebibliography already defined. Or name \end... illegal, see p.192 of the manual. See the LaTeX manual or LaTeX Companion for explanation. Type H <return> for immediate help. ... l.167 \phantom{a} \vspace{3.3cm} ? –  Max Sep 21 '11 at 21:54
    
You're right -- I meant to say \renewenvironment instead of \newenvironment. I've fixed the typo in the answer above. –  Mico Sep 21 '11 at 22:07
    
I feel bad to ask again, but now the code added gives this error: ! You can't use `macro parameter character #' in restricted horizontal mode. <argument> \@biblabel {## 1} l.178 ...enewcommand\theenumiv{\@arabic\c@enumiv}} % ? –  Max Sep 21 '11 at 22:18
    
Did you remember to place the \makeatletter and \makeatother commands around the redefinition of the thebibliography environment? Another possibility: did you replace all three instances of \bibname with \refname (if you're using an article-type document class)? [Can you tell I'm stumbling in the dark?] –  Mico Sep 21 '11 at 22:34
    
Arrgh, just discovered another error, now corrected in the code above. (I hadn't moved the \phantom... commands inside the first brace. Yikes!) Hope it works for you now! –  Mico Sep 21 '11 at 22:45
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.