Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I installed MiKTeX 2.8 and TeXnicCenter on a friend's PC. There seems to be a quite weird issue. There seems to be missing the option "LaTeX=>PDF". Clicking on the arrow to select the output file (e.g. DVI, PDF etc.) nothing appears. That's the 1st issue.

The 2nd one, probably connected to the 1st, occurs while trying to build the file. Clicking the relevant icon, nothing happens!

The package texpdf is installed on her PC as well. I cannot remember if I needed to add something, when I installed my LaTeX.

share|improve this question
1  
Check the "Build / Define Output Profiles" menu. There will be a wizard button at the bottom of that dialog. Use it to find your latex executables and define the default profiles. Shouldn't be any reason to modify the path. –  Mike Renfro Sep 23 '11 at 12:17
1  
did you installed MiKTeX first, then TC oder the other way round? –  Herbert Sep 23 '11 at 12:26
1  
Did you try with a small hello-World-example which uses a standard class like article? –  Ulrike Fischer Sep 23 '11 at 12:42
    
I don't know if this is relevant but, I had a similar problem with WinEdit 5.5. The way I resolved it was by uninstalling and reinstalling WinEdit. BTW - Have you tried compiling with TeXWorks? This will probably indicate whether the problem lies with MiKTeX or TeXNiC. –  Bill Sep 23 '11 at 13:03
1  
@Thanos: no, that is the correct order. When TeXNicCenter is startet first it looks for the MiKTeX directory and you'll have to have to accept the settings before you can use TC. Did you had such a menu on the frist start of TC? –  Herbert Sep 23 '11 at 15:45
show 2 more comments

1 Answer

You have not defined your profiles yet. As stated by Mike Renfro, you can use the TeXnicCenter wizard to guide you through this process. Essentially you need to tell TeXnicCenter where to look for the MiKTeX executables.

On any of my Windows machines, I have MiKTeX saved to [C:\Program Files\MiKTeX 2.9]. However, the executables you need are buried further (for 32-bit) [C:\Program Files\MiKTeX 2.9\miktex\bin] and (for 64-bit) [C:\Program Files\MiKTeX 2.9\miktex\bin\x64]. Below I'll list which executable should be pointed to for each default profile. Note: Your path may be different from mine if you are not using a Windows 7 machine, not using a 64-bit version of MiKTeX, version 2.9 of MiKTeX, or deviated from a default install. However the principles remain the same.

"Path to (La)TeX complier"

C:\Program Files\MiKTeX 2.9\miktex\bin\x64\latex.exe

"Path to BibTeX executable"

C:\Program Files\MiKTeX 2.9\miktex\bin\x64\bibtex.exe

"Path to MakeIndex executable"

C:\Program Files\MiKTeX 2.9\miktex\bin\x64\makeindex.exe

For Viewers, this will completely depend on your personal preference.

The default Viewer for DVI is:

C:\PROGRAM FILES\MIKTEX 2.9\MIKTEX\BIN\X64\YAP.EXE

For PDF, I link to my Adobe Acrobat executable.

For PS, a default GSWin install links me to

C:\Program Files\gs\gs9.04\bin\gswin64.exe

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.