TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am writing a PhD thesis. Some parts of my thesis need to be in French, but the main language is English. I am using

\documentclass[english,letterpaper,12pt,oneside,final]{book}

\usepackage[french, english, USenglish]{babel}

Here is my problem:

\chapter{...} is generating CHAPITRE, which I do not want and it is happening because of the "french" option. But I want CHAPTER as the heading instead of CHAPITRE.

share|improve this question
    
Have a look at tex.stackexchange.com/questions/20987/…, it probably solves your requirements. – Uwe Ziegenhagen Feb 27 at 23:50
    
remove the english option in the documentclass. – Ulrike Fischer Feb 27 at 23:50

Let's see what happens.

  1. You have english as a global option;

  2. You repeat it in the options to babel.

  3. When babel is loaded, the english global option is passed first, then french; when it comes to english, it does nothing, because the relevant .ldf file has already been loaded; the same holds for USenglish.

However, babel sets as main language the one specified in the last loaded language definition file, which in this case is french.ldf.

Solution: don't specify english in the global options, so

\documentclass[letterpaper,12pt,oneside,final]{book}

Alternatively, if you really need the global option, call babel as

\usepackage[french,main=english]{babel}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.