Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use the setspace package to set double spacing throughout the document. It also sets double spacing inside the quote environment. But, I want one half space inside the quote environment. How can this be done?

EDIT 1: If changing font size and font type is also included with the answers, then this Q&A thread will be little more comprehensive.

share|improve this question
add comment

3 Answers

up vote 13 down vote accepted

Using the setspace package you can use \doublespacing for your document and \onehalfspacing inside the quote environment:

\documentclass{article}
\usepackage{setspace}
\usepackage{lipsum}% just to generate filler text

\doublespacing

\begin{document}

\lipsum[1]
\begin{quote}
\onehalfspacing
\lipsum[1]
\end{quote}
\lipsum[1]

\end{document}

If you want this spacing for all the quote environments, then a simple redefinition of the environment will do the job:

\documentclass{article}
\usepackage{setspace}
\usepackage{lipsum}% just to generate filler text

\expandafter\def\expandafter\quote\expandafter{\quote\onehalfspacing}
\doublespacing

\begin{document}

\lipsum[1]
\begin{quote}
\lipsum[1]
\end{quote}
\lipsum[1]

\end{document}
share|improve this answer
    
I think yours does add some different value in the automation. For the user: Note that it holds for all quote environments after it is used. –  Werner Sep 27 '11 at 18:12
    
Redefining the environment did the trick for a document that used custom text styles for spacing, without requiring me to define yet another text style. –  Andrea Wiggins Mar 28 '12 at 16:05
    
When I adjust the spacing inside the quote environment, I get an extra white space above the quote. Any idea what's causing that? I'm working in amsart, in case that's relevant. –  twofeet Sep 13 '13 at 10:08
    
@twofeet please feel free to open a follow-up question. –  Gonzalo Medina Sep 13 '13 at 13:16
add comment

Shameless plug: Use my quoting package and its font option.

\documentclass{article}

\usepackage[doublespacing]{setspace}

\usepackage[font=onehalfspacing]{quoting}

\usepackage[english]{babel}
\usepackage{blindtext}

\begin{document}

\blindtext
% <-- to prevent first-line indentation of the following environment
\begin{quoting}
\blindtext
\end{quoting}

\blindtext

\end{document}
share|improve this answer
add comment

The quote environment provides a group within which you can modify the \doublespacing (from the setspace package) to whatever you want. In this case, just add \onehalfspacing in the quote environment.

\documentclass{article}
\usepackage{setspace}% http://ctan.org/pkg/setspace
\usepackage{lipsum}% http://ctan.org/pkg/lipsum
\begin{document}
\doublespacing% <--- Global line spacing
\lipsum[1]
\begin{quote}
  \onehalfspacing% <--- Local line spacing
  \lipsum[2]
\end{quote}
\lipsum[3]
\end{document}

Different spacing in quote environment

In addition to modifying the local line spacing within the quote environment, you can include any font-related commands. For example, using

\onehalfspacing\small\itshape% Localized font modification

will typeset the quote in small, italicized font:

Modified font in quote environment

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.