TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use biber with biblatex under windows xp. However, when I run it with any argument including biber --help it breaks with the same error message:

Biber/Utils.pm did not return a true value at Biber/Internals.pm line 9.
BEGIN failed--compilation aborted at Biber/Internals.pm line 9.
Compilation failed in require at (eval 31) line 2.
        ...propagated at C:/strawberry/perl/lib/base.pm line 94.
BEGIN failed--compilation aborted at Biber.pm line 6.
Compilation failed in require at script/biber-MSWIN line 18.
BEGIN failed--compilation aborted at script/biber-MSWIN line 18.

The md5 checksum for biber.exe is: 5eaf7f368d940024869231a34f6f9e7f

I do not have Perl installed, but understand that this isn't needed.

share|improve this question

closed as too localized by Marco Daniel, Alan Munn, lockstep, diabonas, Joseph Wright Dec 4 '11 at 17:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Is this still the case with the latest binary? This usually means that the first run of the binary was interrupted so it didn't unpack properly. Try emptying your biber cache (see the biber manual), download the binary again and run it once with "--help" to unpack it. Don't interrupt it until the prompt returns as it's unpacking. After the first run of a new binary, it doesn't need to unpack again and will be faster. – PLK Nov 2 '11 at 9:30
Where did you get the binary from and what is your Tex distribution? If you are using MikTex, try updating all packages by running the Update and Admin Update (and maybe read this question about MikTex setup). – matth Nov 8 '11 at 16:13
I just downloaded a zipped binary from the biber site. My Miktex distribution was version 2.8. I had run all the updates on this though. – aghsmith Dec 2 '11 at 13:29
Thank you for that question! I can't understand why it was closed... – Olivier May 15 '12 at 13:46
up vote 2 down vote accepted

I have now resolved this matter. Though rather brute force, I decided to be contemporary and uninstall MikTeX 2.8, to replace it with version 2.9. Version 2.9 came packed with a functioning version of Biber. This seems to have resolved some other issues I was having also.

An additional fix that I found was to delete the files unpacked by biber in the Temp directory as mentioned here. The temp files may be found under the path:

C:\Users\%USER NAME%\AppData\Local\Temp
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.