Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a LyX and Ubuntu user. I am trying to use a Greek font named kerkis.

I have installed the needed packages in order to enable xelatex in LyX and Greek language:

texlive-xetex texlive-lang-greek texlive-latex-base texlive-latex-recommended

I enabled the option "Use non tex fonts (via Xetex/LuaTeX)" and in my LaTeX preamble I insert the code in order to use the kerkis font:

\usepackage[T1]{fontenc} 
\usepackage{kmath,kerkis}

Although I get an error on LyX. You can see the error on the screeshot:

enter image description here

The error says:

Package polyglossia Error: 
Font \zf@basefont="" not loadable: Metric (TFM) file or installed font not fo

seems to be multiple error.

share|improve this question
    
You are using TeX font packages, so have you tried just not enabling the 'Use non tex fonts ...' option? –  Joseph Wright Sep 28 '11 at 15:47
    
kerkis use type1 fonts with standard TeX-encodings like T1 and LGR (for greek). The thought that you try to use them with xelatex and polyglossia and on top of this through some dark Lyx-interface is reason enough to break out into a cold sweat. Better use an open type font with greek characters. Apart from this: without some code from a minimal example it is very difficult to say if your problem is actually related to kerkis. –  Ulrike Fischer Sep 28 '11 at 16:12
    
@Joseph Wright when i dissable the option "Use non tex fonts.." i dont get an error BUT the text i wrote isnt what i get . I wrote greek δοκιμη and i got something strange ὐῲὐᾢὐὤὐὥὐῴὐᾣ (dont know even if its a language) –  ALdaperan Sep 28 '11 at 16:23
    
@Ulrike Fischer everyone suggested me kerkis font and this is the reason for what i am searching.What code do you need exactly ? i am noob and dont know a lot about latex-lyx :( –  ALdaperan Sep 28 '11 at 16:23
    
But did "everyone" know and understand that you want to use xelatex? kerkis will work fine with pdflatex + babel but for xelatex with polyglossia it is the wrong choice. Regarding the code: As far as I know you can export the lyx code to a file. Together with the log-file would enable me to understand what you are doing and where the problem is. But it will probably not be of much use as you wouldn't know how to feed back the correction. Better use a greek font through the normal polyglossia interface. See e.g. tex.stackexchange.com/questions/24728/… –  Ulrike Fischer Sep 28 '11 at 16:43

1 Answer 1

up vote 4 down vote accepted

Community wiki solution by the OP ALdaperan, as said in the comments:

  • Disable the option "use non TeX fonts"
  • In the tab Language choose encoding Greek ISO (8859-7) or default encoding
  • As in the question - use T1 encoding, i.e. add \usepackage[T1]{fontenc} to the preamble with loading kmath and kerkis
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.