Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using the texlive distribution on Arch Linux. I have:

\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=mla]{biblatex}
\bibliography{sources.bib}
...

In sources.bib I have:

@article{taylor,
%...
howpublished = {Web},
url = {http://www.etc.com/blah/blah/blah}
}

Everything shows up except the url. I've also tried putting \usepackage{url} in the preamble and changing the url line to url = {\url{http://www.etc.com/blah/blah/blah}} and it makes no difference.

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

The newest edition of the MLA Handbook recommends against showing the URL. If you'd like to go against these recommendations and use something close to the previous edition, add the package option showmedium=false to the preamble:

\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=mla,showmedium=false]{biblatex}
\bibliography{sources.bib}

Watch out, though, as this option attempts to retain previous stylings without making any promises. In your example, among other things, both "Web" and the period following it will be missing.

One nice thing to keep in mind about the default usage: URLs for eprint sources, while always being hidden from print, still nevertheless supercharge the PDF. Check out the following Bibtex entry as an example:

@article{barrowsaa,    
    Author = {Adam Barrows},    
    Eprint = {http://muse.jhu.edu/journals/modern_fiction_studies/v056/56.2.barrows.html},    
    Eprinttype = {muse},    
    Issue = {Summer},    
    Journal = {Modern Fiction Studies},    
    Number = {2},    
    Pages = {262--289},    
    Title = {`The Shortcomings of Timetables': Greenwich, Modernism, and the Limits of Modernity.},    
    Url = {http://muse.jhu.edu/journals/modern_fiction_studies/v056/56.2.barrows.html},    
    Urldate = {2011-02-17},    
    Volume = {56},    
    Year = {2010}}

Here's the resulting text, with the database text (Project Muse) functioning as a hyperlink to the article:

Barrows, Adam. “‘The Shortcomings of Timetables’: Greenwich, Modernism, and the Limits of Modernity.” Modern Fiction Studies 56.2 (Summer 2010): 262–289. Project Muse. Web. 17 Feb. 2011.

share|improve this answer
    
Thanks. I didn't realised the latest MLA recommendation was not to show the URL. I thought I was doing something wrong in my .tex or .bib files. –  Wolf Sep 29 '11 at 9:14
    
Well the option remains per publisher still to show it. (There are always caveats, tradeoffs, and qualifications.) It makes sense to me to make options to print the URL at the end of the entry, so I'll see about adding it in an upcoming release. –  James Clawson Oct 4 '11 at 3:24
    
Thanks for this post, now I don’t need to search around any longer. I would heartly welcome an option to toggle url + also access date visibility apart from the settings of the latest style guide edition since it seems odd to quote for instance a video from youtube w/o pointing the reader to the URL. Best, Jakob PS: Sorry for posting this as another answer, I meant it to be a comment. –  Jakob Mar 3 '12 at 19:27
    
Jakob, it seems the best option would include a modification of the @video entrytype that supports a URL. I'll add that to my list of issues for an upcoming release. –  James Clawson Mar 25 '13 at 0:22
add comment

I've moved Biblatex-MLA development to GitHub:

https://github.com/jmclawson/biblatex-mla/tree/dev

In this development branch, I've added support for an @online entrytype, and I've added support for the noremoteinfo package option, which defaults to "true." By setting "noremoteinfo=false" as a package option when you load Biblatex, the URL will be printed at the end of each entry. (Whether or not you set that option, the word "Web" will now also serve as a link in the PDF to the URL using hyperref.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.