Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the pre-release testing version of TeXlive 2010. From what I understand from the TeXlive Guide, a new feature is that support for magin kerning has been added to XeTeX.

From what I can tell, it is not enabled by default, though I'm not certain about that. (The effect might be subtle enough that I cannot tell.)

Is it possible for me to enable this when compiling a more or less standard XeLaTeX document? If so, how? The microtype package still throws an error when I try to use it with xelatex. Will there be an updated version of this package?

Will it be necessary to use certain fonts, or prepare/acquire a special configuration file for each font?

Anyway, I can find very little information about this new feature online. Any light that can be shed would be appreciated.

share|improve this question
    
Margin kerning can be seen easily. All punctuation (hyphens, commas, ...) at the end of a line are placed a little further to the right, so the right margin of the body of text is formed by the letters, but not by the punctuation. –  Roman Plášil Sep 11 '10 at 7:36
5  
One of my favourite uses for the geometry package's showframe option is to tell for certain how much margin kerning is going on. (Load it with the pass option if you want to restrict it to just this task.) –  Geoffrey Jones Sep 11 '10 at 8:39
    
Thanks for the suggestion, Geoffrey. This makes it easy to see that there's definitely no margin kerning going on by default. –  frabjous Sep 11 '10 at 13:10
add comment

1 Answer

up vote 11 down vote accepted

You need to install a preliminary version of the microtype package.

share|improve this answer
    
Thanks! (I'm marking this as right; it's a bit hard to tell with the site down, but I'm taking your word for it. ;) ) –  frabjous Sep 12 '10 at 2:15
    
You can get it here: tlcontrib.metatex.org/cgi-bin/package.cgi/action=view/id=423 –  Jörg Mar 19 '12 at 20:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.