Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've just installed TeXlipse using the simple installing option (Install new softwares -> http://texlipse.sourceforge.net/) on my Mac OS.

I create a new LaTeX project, select output format = pdf, build command = pdflatex. However, no pdf file was generated. I tried to turn off automatically build and then clicked build but still nothing happened.

In console, it's written:

/usr/bin/open -a /System/Library/CoreServices/Finder.app "/Users/myusername/Documents/workspace/TexLipse"

Can someone please explain me how to build pdf file with TeXlipse in Mac OS X?

share|improve this question
1  
How did you install your TeX distribution? (Not TeXlipse itself, but your actual TeX distribution? You should be using MacTeX. –  Alan Munn Sep 30 '11 at 21:39
1  
Thanks. I've just installed MacTex now. –  chepukha Oct 3 '11 at 15:16
    
i think i have a similar issue. i've set up all the right paths, but the building process halts at 4% and the console output is: running: /usr/local/texlive/2011/bin/x86_64-darwin/pdflatex pdflatex> This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011) pdflatex> restricted \write18 enabled. running pdflatex from the console works and compiles perfectly any hints? –  simon Feb 18 '12 at 10:36
    
@simon This is not an answer to the question. If the accepted answer does not solve your problem, consider asking a fresh question specific to your problem. –  qubyte Feb 18 '12 at 10:51
    
@simon: Welcome to TeX.sx! Your question won't be seen by many people here, so it would be best to repost it as a fresh question. Follow-up questions like this are more than welcome! Please use the "Ask Question" link for your new question; there you can link to this question to provide the background. –  Werner Feb 18 '12 at 15:30

1 Answer 1

up vote 1 down vote accepted

I suspect something went wrong with the configuration of the builder settings. I had a similar problem which required me to reconfigure that part of the installation process. When I clicked Build nothing happened, but after fixing this it works.

See the screenshot below and the following url Texclipse installation and configuration - Part 2

enter image description here

Insert /usr/texbin where it asks for the "Bin directory of TeX distribution". This will access the files at /usr/local/texlive/2011/bin if you've got the 2011 version of MacTeX installed.

share|improve this answer
    
I think you're right, Mcgafter. However, I'm not sure how to setup these paths in Mac OS. The only directory I found for texlipse is /Users/usrname/Documents/software/eclipse/plugins/net.sourceforge.texlipse_1.4.2 but when I hit apply button, nothing is set. I tried to setup the path to each program, e.g. pdflatex, but I only found texi2pdf in /usr/bin and setting pdflatex to that one doesn't help. Any thought on that? –  chepukha Sep 30 '11 at 15:27
1  
If MacTeX has been installed, /usr/texbin should be used instead of the path to the executables. It's probably better to leave, say, latex in the first line and filling the box "Bin directory" with /usr/texbin. In theory, at least. (I don't have Eclipse to make a try.) –  egreg Sep 30 '11 at 15:32
    
Thanks, egreg. But there is no /usr/texbin as well as anything start with "tex" –  chepukha Sep 30 '11 at 16:14
    
Mcgafter, I couldn't find /usr/local/texlive/2011/bin directory. –  chepukha Sep 30 '11 at 16:44
    
@chepukha: Use egreg's path which he mentioned. /usr/texbin. That will automatically redirect to the proper installed path. If you've got 2010's MacTeX version it might be /usr/local/texlive/2010/bin. The /usr directory is hidden by default. To view it's contents select Go->Go to folder from a Finder window and type in /usr/ in the box. You could also use a tool such as TinkerTool or OnyX to display hidden files and folders if you really want to. –  McGafter Oct 1 '11 at 9:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.