Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
(/localhost/texlive/2011/texmf-dist/tex/latex/oberdiek/rerunfilecheck.sty))
(/localhost/texlive/2011/texmf-dist/tex/generic/oberdiek/se-ascii-print.def)
(./TikZ-commands.tex)
(/localhost/texlive/2011/texmf-dist/tex/latex/biblatex/lbx/australian.lbx
(/localhost/texlive/2011/texmf-dist/tex/latex/biblatex/lbx/british.lbx
(/localhost/texlive/2011/texmf-dist/tex/latex/biblatex/lbx/english.lbx)))

! Package biblatex Error: Patching 'tabularx' failed.

See the biblatex package documentation for explanation. Type  H <return>  for immediate help.  ...                                    

                                                   l.251 \begin{document}
                       ? H This is an internal issue typically caused by a conflict between biblatex and some other package. Modifying the package loading order may fix the problem. ?

I get the above error message when I compile a book manuscript using the memoir class and many packages under XeLaTeX.

If I press on, I am able to compile the document but wish to remove the cause of this error.

I do not explicitly use the tabularx package but do use longtable.

I am able to supply more details but cannot make a minimal example just yet. I ma using TeXLive 2011 updated today and the vintage of biblatex.sty is

$Id: biblatex.sty,v 1.6 2011/07/29 19:21:28 lehman stable $  programmable bibliographies

EDIT: Sorry for not originally including the MWE; here it is:

\documentclass{memoir}
\usepackage{fontspec}
\usepackage[backend=biber,babel=none,language=australian,sorting=none,style=numeric-comp,hyperref=auto]{biblatex}
\usepackage{hyperref}
\begin{document}
This is a minimal working example for the bug reported at \url{http://tex.stackexchange.com/questions/30148/biblatex-and-tabular-patching-error-message}.
\end{document}

I get the same error message as reported above.

share|improve this question
1  
I think you really need to provide more information. Otherwise it's too hard to figure out what's going wrong here. –  Thorsten Oct 1 '11 at 12:20
    
@chandra: Please add a minimal working example (MWE) that illustrates your problem. –  Joseph Wright Oct 1 '11 at 12:23
add comment

1 Answer

up vote 10 down vote accepted

The problem is an incompatibility between biblatex and the lastest version 6.82i of hyperref. By default (i.e., with the hyperfootnotes option enabled), hyperref will redefine the tabularx/memoir macro \TX@endtabularx. This in turn causes the biblatex redefinition of the same macro to fail and produce the observed error message. As a workaround, load hyperref with the option hyperfootnotes=false.

\documentclass{memoir}
\usepackage{fontspec}
\usepackage[backend=biber,babel=none,language=australian,sorting=none,style=numeric-comp,hyperref=auto]{biblatex}
\usepackage[hyperfootnotes=false]{hyperref}
\begin{document}
This is a minimal working example for the bug reported at \url{http://tex.stackexchange.com/questions/30148/biblatex-and-tabular-patching-error-message}.
\end{document}

UPDATE: This behaviour is fixed in hyperref 6.82j/biblatex 1.7.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.