Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The answers to this question already explain how to remove the borders around hyperlinks.

However, if I submit a manuscript to Arxiv.org, it seems that their system somehow manages to override the \hypersetup command. The end result is ugly: bright green, red, and cyan boxes all around the PDF file. However, it does not just ignore all \hypersetup commands; for example, \hypersetup{pdfauthor=...} works as expected.

Does anyone happen to know any workarounds?

AFAIK, Arxiv.org uses a system that is based on Texlive 2009 and TeX::AutoTeX. I am defining \pdfoutput=1, i.e., the document is compiled using pdflatex.

share|improve this question
1  
@lockstep: Why the obsolete tag? –  Caramdir Oct 4 '11 at 0:59
    
@Caramdir: In his answer, Jukka pointed out that a "too old" version of hyperref was the problem. –  lockstep Oct 4 '11 at 5:29
1  
@lockstep: I'd see Jukka's second answer (hyperref.cfg changes) as the actual problem. –  Caramdir Oct 4 '11 at 18:29
add comment

3 Answers

I was sure that the arXiv FAQ had an answer to this, but all it has is this, which tells you how to disable automatic hyperref. I don't do this, but it will certainly work if you simply create at 00README.XXX file, say nohypertex in it, and just roll your own hyperlinks (it won't ignore anything you write in the document; this will just disable its own attempts at hyperlinking). I remember I did this in the first version of my first paper.

In any case, my own papers seem to have no special provisions: I have \pdfoutput=1 at the top, and then \usepackage[colorlinks]{hyperref} later. I also have a \hypersetup changing some link colors, which is obeyed.

Do you put colorlinks in the \usepackage or the \hypersetup? Try doing the former. The hyperref manual suggests that some options have "restricted" use, so this may make a difference.

Finally, it's possible that the arXiv scripts are to blame here: perhaps they detect the loading of \hyperref and modify their own use of it accordingly.

Edit: Although you seem to have gotten some use from what I wrote, it does indeed look like the arXiv is ignoring the pdfborder = {0 0 0} directive. One workaround that I tested myself is to use the alternative command linkbordercolor = {1 1 1} (i.e. white), which is not ignored. I don't know what was going on with the other option, unfortunately. 00README.XXX is not required.

share|improve this answer
    
00README.XXX with nohypertex does not help. It does not matter if I put pdfborder={0 0 0} in \usepackage or \hypersetup; in both cases it is ignored, even if I use nohypertex. –  Jukka Suomela Oct 2 '11 at 16:31
    
@Jukka: Suppose you just try to remove all hyperlinks entirely. Does 00README.XXX work for that (i.e. does it work as intended at all)? Perhaps you could test this with a fake MWE submission for easier debugging. –  Ryan Reich Oct 2 '11 at 16:37
add comment
up vote 13 down vote accepted

With a lot of trial and error, I finally found a solution. This works:

\pdfoutput=1
...
\usepackage{hyperref}
...
\hypersetup{
    colorlinks=true,
    linkcolor=black,
    citecolor=black,
    filecolor=black,
    urlcolor=black,
}

The links are invisible, there are no borders or colours. Trickery with 00README.XXX does not seem to be necessary.


Some remarks…

Any approach based on pdfborder={0 0 0} seems to fail. Options hidelinks and allcolors are not supported; the hyperref version that Arxiv.org uses is too old.

I realised that I have to enable colorlinks only after reading Ryan Reich's answer, in which he mentions that the colorlinks option and customised link colours seem to work fine.

I still do not understand exactly what is going on here—how is it possible that colorlinks disables borders while pdfborder does not work? Anyway, I guess I will just blindly copy-and-paste this fragment of code in future and forget about it. :)

share|improve this answer
add comment

I received the following answer by email from Thorsten Schwander; I am quoting it here with his permission (with some formatting):

arXiv sets \pdfborderstyle in its hyperref.cfg

depending on where your \hypersetup is placed and what options you set, this may take preference.

the current settings in arXiv's /texlive/2009/texmf-config/tex/latex/latexconfig/hyperref.cfg:

\hypersetup{
 linktocpage=true,
 pdfborderstyle={/S/S/W 1},
 hyperindex=true,
 bookmarks=true,
 bookmarksopen=true,
 bookmarksnumbered=true,
}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.