Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing an essay and I need to have superscript citations in either Chicago or MLA style. After a bit of searching (and a false start with natbib) this question seemed to indicate that Chicago with biblatex and biblatex-chicago would work. However I'll be darned if I can figured out the documentation for the two. The biblatex-chicago doesn't seem to have an example of how to set it up, and I got conflict messages when I tried to load biblatex then biblatex-chicago so I went for the simplest option, which was to use \usepackage[style=chicago-notes]{biblatex} as follows:

\documentclass[12pt,letterpaper]{article}
\usepackage[style=chicago-notes]{biblatex}
\addbibresource{test.bib}

\begin{document}
``The adherence of England to a military system, inherited from the last century, can only be explained by her insular position and the security from invasion afforded by a powerful navy.'' --Emory Upton \cite[268]{Upton}
\printbibliography
\end{document}

In test.bib I have:

@book{Upton,
  title={The armies of Asia and Europe: embracing official reports on the armies of Japan, China, India, Persia, Italy, Russia, Austria, Germany, France, and England.},
  author={Upton, Emory},
  year={1878},
  publisher={Griffin \& co.}
}

I then get the error:

[...]
Package biblatex Info: Redefining '\fullcite'. ! LaTeX Error:
\lbx@fromlang undefined.

Can someone point out what I'm doing wrong? I've tried to make a minimal example, but I can't get things to work. I'm on TeXLive 2011.

If you can't figure this out I'll also take answers that will get me either MLA or Chicago style with superscript citations that let me specify page number at the time of citation, since I'm going to be making dozens of citations to 2 or 3 books.

Note I made an even more minimal example:

\documentclass[12pt,letterpaper]{article}
\usepackage[style=chicago-notes]{biblatex}

\begin{document}
\end{document}

How on earth am I messing this up? According to TeXStudio the error is at

chicago-notes.cbx line 2493: \lbx@fromlang undefined. \renewcommand*{\lbx@fromlang}

Thank you for your help.

Output of \listfiles

 *File List*
 article.cls    2007/10/19 v1.4h Standard LaTeX document class
  size12.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
biblatex.sty    2011/07/29 v1.6 programmable bibliographies
etoolbox.sty    2011/01/03 v2.1 e-TeX tools for LaTeX
    etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
  logreq.sty    2010/08/04 v1.0 xml request logger
  logreq.def    2010/08/04 v1.0 logreq spec v1.0
  ifthen.sty    2001/05/26 v1.1c Standard LaTeX ifthen package (DPC)
     url.sty    2006/04/12  ver 3.3  Verb mode for urls, etc.
blx-compat.def    2011/07/29 v1.6 biblatex generic compatibility
biblatex.def    2011/07/29 v1.6 biblatex generic definitions
chicago-notes.bbx    2011/03/17 v 1.3 biblatex bibliography style
chicago-notes.cbx    2011/03/17 v 1.3 biblatex citation style
biblatex.cfg    
 english.lbx    2011/07/29 v1.6 biblatex localization
share|improve this question
2  
The example compiles correctly for me. Can you show the output of \listfiles? –  egreg Oct 2 '11 at 23:10
    
I have so complied. –  Canageek Oct 2 '11 at 23:17
1  
I have 2011/09/28 as the date for the chicago-notes files. –  egreg Oct 2 '11 at 23:19
1  
Your .bbx and .cbx files are out of date. Mine are 2011/09/21 v 1.6, so you need to update your biblatex-chicago package. (And apparently even that's out of date.) –  Alan Munn Oct 2 '11 at 23:23
    
Updating TeXLive got it to compile, but it is giving me Author-date format. –  Canageek Oct 2 '11 at 23:56
add comment

1 Answer

up vote 8 down vote accepted

The following minimal example works for me. Note that biblatex-chicago now requires the use of biber as opposed to bibtex if you are using author-date style or if your .bib file is UTF-8 encoded.

\documentclass{article}
\usepackage[nopar]{lipsum} % for dummy text
\usepackage[american]{babel}
\usepackage[babel]{csquotes}
\usepackage[notes,natbib,isbn=false,backend=biber]{biblatex-chicago}  
\begin{filecontents}{\jobname.bib}
@book{Saussure1995,
    Author = {Ferdinand de Saussure},
    Origyear = {1916},
    Publisher = {Payot},
    Title = {Cours de Linguistique G{\'e}n{\'e}rale},
    Year = {1995}}

@book{Labov1972,
    Address = {Philadelphia},
    Author = {William Labov},
    Publisher = {University of Pennsylvania Press},
    Title = {Sociolinguistic Patterns},
    Year = {1972}}

\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}


\lipsum[1]\autocite{Saussure1995}

\lipsum[2]\autocite{Labov1972}


\end{document}

Here are some extra considerations on using biblatex:

  • Make sure your TeX distribution is completely up-to-date. biblatex, biber, and the bibliography styles that depend on them are being actively developed, and small changes might have big effects.
  • biblatex is increasingly becoming dependent on biber as a backend (as opposed to bibtex) and although some packages work with both, you may want to consider using biber if you are using biblatex at all.
  • biblatex generates a lot of auxiliary files with various extensions that your editing environment may not be aware of. It is also sensitive to corrupted or incomplete aux files, so it's a good idea to manually delete them if you are encountering problems. This is especially true if you are trying to switch between using biber and using bibtex on the same file.
  • The basic command for using biber is:

    biber <file>.bcf
    

    You may need to adjust your editing environment preferences to use it from within the editor.

share|improve this answer
    
So I should replace bibtex with biber in my command line chain? –  Canageek Oct 2 '11 at 23:17
    
That does not compile for me with the same error- and that is with just a run of PDFLaTeX, no BibTeX or biber- I'm wondering if my copy of chicago-notes.cbx has gotten damage somehow? –  Canageek Oct 2 '11 at 23:19
1  
No, you can keep your file as it is. Biber will adapt to whatever encoding is used, basically. I use the same bib file with both biber and bibtex with no difficulty. It's ASCII. –  Alan Munn Oct 2 '11 at 23:26
1  
With respect to changing your command line chain, it might be useful to have a version using biber and one using bibtex if you are likely to be flipping between using biber and bibtex. If you start to switch over to using biblatex it will increasingly be dependent on biber, although at the moment it is still compatible with bibtex. –  Alan Munn Oct 2 '11 at 23:41
1  
Sadly I'm using TeXStudio, so my command chain is whatever I code into the button- I might as well move to biber if it is better, so long as it won't screw up my other work. –  Canageek Oct 3 '11 at 0:14
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.