Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use the package biblatex-apa with babel. It is working except that the APA style requires that parenthetical citations and bibliography references separate the last author by "&" and not by "and".

The following shows the options I'm using:

\usepackage[spanish]{babel}
\usepackage{csquotes}
\usepackage[style=apa]{biblatex}
\DeclareLanguageMapping{spanish}{spanish-apa}

However, though apa.bbx is meant to handle it, instead of "&" it is compiling with "y" (Spanish for and).

How can I manage to compile according to the APA style requirements?

share|improve this question
add comment

2 Answers

This is a problem due to the biblatex spanish.lbx which spanish-apa.lbx inherits from. It uses a "smart and" which is replacing ampersands. Add this to your preamble.

\setcounter{smartand}{0}

I'll update the APA style with this option for spanish.

share|improve this answer
    
Thank you for your answer. I've editted my answer so that it incorporates both your solution to the bibliography and the workaround for truncated citations –  Víctor H Cervantes Oct 5 '11 at 19:24
add comment
\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[spanish]{babel}
\usepackage{csquotes}
\usepackage[style=apa,backend=biber]{biblatex}
\DeclareLanguageMapping{spanish}{spanish-apa}


\setcounter{smartand}{0}
\DefineBibliographyStrings{spanish}{%
    andothers = {et al.},
}

\addbibresource{biblatex-examples.bib}

\begin{document}
Texto de relleno \parencite{bertram,companion}.
Texto de relleno \parencites{bertram,companion}.
Texto de relleno \textcite{bertram}.
\printbibliography
\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.