Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having a problem with biblatex, where the citations look like [XYZ05] but the entries in the bibliography are simply numeric like [1]. Here are my package options:

\usepackage[firstinits=false,sorting=none,bibstyle=ieee,
citestyle=alphabetic,maxnames=99,doi=false,url=false,isbn=false]{biblatex}

and I generate the bibliography with calls like

\printbibliography[heading=subbibliography,keyword=conference,title=Conferences]

You can see the generated file at http://dave-pritchard.net/tmp/cv.pdf and notice that the hyperlinks from citations to bibliographic entries even work! So the things are connected in some sense, it is just the superficial label in the bibliography which is printing wrong. What could cause printbibliography to ignore my citestyle?

Updated as per Marco's comment: I am using ieee.bbx as a bibstyle (in fact a derivative but the problem is equally bad with either). So I hope the problem is better phrased as:

in ieee.bbx, how can I change the labels attached to each bibliographic entry, to be the same as in alphabetic.cbx?

share|improve this question
    
What could cause printbibliography to ignore my citestyle? -- I think your definition. Sorry but nobody knows your bibstyle. Please provide a minimal example. –  Marco Daniel Oct 5 '11 at 18:20
    
@Marco: thanks. I had no idea that the .cbx and .bbx file would each provide their own way of generating labels, to me it's a weird system. Anyway I still have a problem but I hope it's phrased clearly now, please see the revision. –  daveagp Oct 5 '11 at 19:08
add comment

1 Answer

up vote 6 down vote accepted

As the IEEE use a numerical style, you will need to add some code from alphabetical styles into your source. Add the labelalpha option to those used when loading biblatex, to come after the bibstyle=ieee option, and add the following code after loading biblatex:

\defbibenvironment{bibliography}
  {\list
     {\printtext[labelalphawidth]{%
        \printfield{prefixnumber}%
    \printfield{labelalpha}%
        \printfield{extraalpha}}}
     {\setlength{\labelwidth}{\labelalphawidth}%
      \setlength{\leftmargin}{\labelwidth}%
      \setlength{\labelsep}{\biblabelsep}%
      \addtolength{\leftmargin}{\labelsep}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}%
      \renewcommand*{\makelabel}[1]{##1\hss}}
  {\endlist}
  {\item}
\DeclareFieldFormat{labelalphawidth}{\mkbibbrackets{#1}}
share|improve this answer
    
If this is not quite right, a short minimal example would be useful. –  Joseph Wright Oct 5 '11 at 19:36
    
It does work, you are Wright! It also seems to work just as well when I append it to my .bbx file, which is nice since I don't need to add it again to my next latex source file. Thanks! –  daveagp Oct 5 '11 at 19:52
    
@daveagp I assume your .bbx is a copy of ieee.bbx, as it's never a good idea to alter the one in your TeX distribution directly. –  Joseph Wright Oct 5 '11 at 19:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.