Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question is (almost) exactly the same as this one : How to write directly French characters in Emacs and print them in LaTeX? You may read his question instead of mine, the only difference (I spotted) is that the OP uses Emacs and I use Windows Vista and Miktex. I have tried the proposed solution, but it doesn't work on my computer. Unfortunately, I can't post comments below the answer.

I am using Miktex (on Windows Vista) which I only recently downloaded ("complete" version). I have encountered problems with special characters. I can't write é,è,à... directly on my keyboard, instead I have to write \'e, \`e, \`a etc which is very cumbersome.

I am really ignorant when it comes to computers and software, I hope somebody can help me resolve this issue!

EDIT : I am using Texmaker. Also, I downloaded the complete Miktex from a french university but didn't get any further packages. Is the package babel included in the "complete Miktex" download?

Finally, when I say the proposed solution doesn't work

share|improve this question
    
Perhaps this is also a duplicate of this question: How to write special/accented characters in LaTeX If you can type them directly in other applications, you can use them directly in your LaTeX source. You need to make your question clearer. What part of the linked question doesn't work for you? What editor are you using? (MikTeX is a distribution, and Windows is an operating system.) How are you inputting your source? –  Alan Munn Oct 5 '11 at 23:31
    
If you have a full MikTeX installation, you should also have TeXworks. That is a very friendly editor that will allow you to enter accented characters directly if you use the latex examples given in either of the linked questions. –  Alan Munn Oct 5 '11 at 23:38
    
@Alan Munn I tried it on TeXworks, and it did work, thanks! Why does it not compile correctly on TeXmaker? –  Olivier Bégassat Oct 5 '11 at 23:42
    
Probably TeXmaker uses a different encoding (latin1 instead of utf8) –  Caramdir Oct 5 '11 at 23:46
    
@Caramdir I replaced utf8 with latin1 and it works :D thanks! –  Olivier Bégassat Oct 5 '11 at 23:52

3 Answers 3

up vote 7 down vote accepted

The problem is that TeXmaker seems to encode the files in Latin-1 instead of UTF-8. Latin-1 is an obsolete encoding standard, but there is still a lot of software that hasn't switched to using Unicode yet.

If you use

\usepackage[utf8]{inputenc}

then LaTeX obviously gets confused when the file is actually encoded in Latin-1.

You have two options:

  1. Configure TeXmaker to use UTF-8: in Options → Configure TeXmaker → Editor set “Editor Font Encoding” to UTF-8 (thanks, @Torbjorn).
  2. You can use

     \usepackage[latin1]{inputenc}
    

    instead.

Going forward I'd recommend the first option as UTF-8 is what more and more software is going to use (as it solves a lot of long-standing problems). But the second option is certainly a fast workaround for existing files. Alternatively there are of course many other editors that use UTF-8 by default.

share|improve this answer
    
There is a setting in TeXmaker to use UTF-8: Options --> Configure TeXmaker --> Editor. Set "Editor Font Encoding" to UTF-8. (I actually thought this was the default, but perhaps I was mistaken.) –  Torbjørn T. Oct 6 '11 at 0:33
    
@TorbjornT. Thank you. I don't use TeXmaker so I didn't know whether that was possible. I edited the answer accordingly. –  Caramdir Oct 6 '11 at 0:43
    
@TorbjornT. Just noticed: is it really “Editor Font Encoding”? –  Caramdir Oct 6 '11 at 0:45
    
That's what it says in the options, could just be a bad translation. Edit: See for example movingtowardslinux.files.wordpress.com/2011/01/texmaker.png –  Torbjørn T. Oct 6 '11 at 0:49
    
Thank you for your answer. I tried changing the editor font encoding (EFE) to UTF-8 but then I can't load my .tex files. I have to go back to the EFE called System. If I then change the .tex file to incorporate \usepackage[utf8]{inputenc}, save it and restart the procedure with the UTF-8 EFE it still won't work... Why should I switch to UTF-8 in the future? EDIT you do adress that, never mind! –  Olivier Bégassat Oct 7 '11 at 7:13

I assume you already have a keyboard that lets you directly enter various accented characters. MikTeX is a "back end," i.e., it'll take various input files and pass them to TeX/pdfTEX/XeTeX/luatex/bibtex/etc for processing. (Its output will generally be a .pdf file and several auxiliary log files. What you need, now, is a text editor program or "front end" that lets you enter the text that MikTeX will then process. Most importantly, the front end software should be "TeX-aware" in the sense that it highlights matching parentheses, brackets, and braces, it should highlight various common keywords, render text in comments in a different color than "ordinary text", etc.

I suggest you consult the answers to the questions LaTeX Editors/IDEs and Editors supporting unicode for opinions by other users of TeX Stack Exchange. Obviously, there's no single "best" editor for everyone. (For what it's worth, two of my favorite editors that run on Windows platforms are winedt (very well integrated with MikTeX; shareware -- at $30 for a personal license, it's not exactly expensive) and TeXworks-- the latter program is available for all kinds of platforms besides Windows, by the way.) Happy TeXing!

share|improve this answer

If you mean that you have problem with TeXMaker to stop doing the "special" accents like á,à,ã... and the only thing you can type is ~a,'a, etc. (when you pres accented letters on keyboard) I guess it's a SCIM config problem. For Linux like operating system I fix the problem installing the ibus-qt4 package:

Debian/Ubuntu:

$>sudo apt-get install ibus-qt4

or Fedora equivalent:

$>yum install ibus-qt

But for Windows you should check what kind of library is installed in package ibus-qt4 and install similarly DLL on you machine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.