Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to LaTeX. I am trying to write a paper using latex. I want a footnote about the funding source of my work in the first page without marker.

I tried below approaches:

  1. \footnotetext{text goes here} This creates a footnote but with '0' as marker. However, the marker reference does not appear within the normal text where I placed this command.

  2. Used \def\blfootnote{\xdef\@thefnmark{}\@footnotetext} definition provided at http://help-csli.stanford.edu/tex/latex-footnotes.shtml#unnumber. I placed this definition in the main tex file just after package declaration. But, this gives the below error.

       ! Use of \@ doesn't match its definition.
       \blfootnote ->\xdef \@thefnmark{}\@f
                                           ootnotetext
    
share|improve this question
    
Welcome to TeX.sx! You don't have to sign with your name since it automatically appears in the lower right corner of your post. You can use backticks ` to mark your inline code as I did in my edit. –  Joseph Wright Oct 6 '11 at 18:54
4  
Additional to/instead of posting a “Thank you” as comment, it would be nice to upvote some answer(s) (with the upward pointing arrow to the left of it - if you did not do so already). More than one answer to a question can be upvoted). Since you have two responses below that seem to answer your question, please consider marking one of them as ‘Accepted’ by clicking on the tickmark below their vote count. This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). –  Stephen Oct 30 '11 at 18:32

2 Answers 2

As Stephen mentioned in his answer, if you're using your definition in your .tex file, you need to enclose it inside \makeatletter, \makeatother. Another option not involving the use of the special character @ (thus not requiring \makeatletter, \makeatother) would be to locally redefine \thefootnote (taking care of correcting the footnote counter):

\documentclass{article}
\usepackage{lipsum}

\newcommand\blfootnote[1]{%
  \begingroup
  \renewcommand\thefootnote{}\footnote{#1}%
  \addtocounter{footnote}{-1}%
  \endgroup
}

\begin{document}

Some text\blfootnote{A footnote without marker} and some more text\footnote{A standard footnote}

\end{document}

enter image description here

share|improve this answer
    
Thanks for the responses guys. Just looked at your suggestions, but was able to have the footnote working just sometime ago. The problem was that I had to keep the definition of blfootnote in the class file instead of the tex file. –  Rajesh Oct 6 '11 at 19:18
    
@Rajesh: as Stephen mentioned in his answer, enclosing your definition with \makeatletter, \makeatother you can keep the definition in the .tex file. See also my updated answer for another option not involving internal commands. –  Gonzalo Medina Oct 6 '11 at 19:21
    
What does "bl" in "blfootnote" stand for? –  David Doria Oct 24 '12 at 15:14

@ is a special character in (La)TeX. Enclose your code with \makeatletter, \makeatother:

\makeatletter
\def\blfootnote{\gdef\@thefnmark{}\@footnotetext}
\makeatother

Edit (from my former comments):

Internal commands with @ can be used without \makeatletter and \makeatother in the class file (as you found out) as well as in style files, too. Only in the .tex file the "envelope" is needed. That said, I would prefer Gonzalo Medina's answer over my own (or your placement of the redefinition in the class file) because it only locally redefines footnote (respectively give a new command for unnumbered footnotes).

When you are using the hyperref package, you would probably want to add \addtocounter{Hfootnote}{-1}% to the code of GM, otherwise it will work but error messages about (hyper)footnotes will become tricky, because e.g. Hfootnote 42 then is footnote 41 - use \addtocounter{footnote}{-1} without \addtocounter{Hfootnote}{-1} for several cases, and the difference between footnote and Hfootnote makes debugging harder than necessary.

Edit (again):

As suggested by egreg, I changed \xdef (=\global\edef) to \gdef (=\global\def), because there is no need to *e*xpand the *def*inition's content here (as it is just empty).

share|improve this answer
    
\xdef should be \gdef; it doesn't make any difference here, it could in other situations. –  egreg Oct 30 '11 at 18:53
    
+1, @Gonzalo Medina solution doesn't work 'well' with hyperref package, it lets an empty link box to the footnote! –  Kevin Oct 29 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.