Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My setup is generating DVI output vs PDF when using pstricks with Aquamacs 2.3a and MacTex 2011

Simple latex files will create pdf files as expected from inside aquamacs and auto view in skim. When using .tex files with PS graphics, the only file that gets generated is DVI. Via command line the file correctly converts to PDF with dvipdf.

A just previous setup with same .tex file was auto generating PDF's fine by setting the --shell-escape in the latex customization in Aquamacs. Both Tex Live (MacTex) and Aquamacs were updated, but I suspect issue with Aquamacs settings.

What are the changes to Aquamacs to get back to automatically working scenario.

Old (working) from previous setup was

This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010) (format=pdflatex 2010.7.21)  18 SEP 2011 10:08
entering extended mode
 \write18 enabled
 %&-line parsing enabled.
**\input test.tex

New settings that will only produce DVI

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011) (format=latex 2011.7.3)  7 OCT 2011 09:44
entering extended mode
restricted \write18 enabled.
 Source specials enabled.
 %&-line parsing enabled.
\pdfoutput=0  \input test.tex
share|improve this question
    
Does this post help: tex.stackexchange.com/questions/8413/… –  cmhughes Oct 7 '11 at 20:01
    
run the document with xelatex instead of pdflatex. Then you do not need the "shell-escape" option. –  Herbert Oct 7 '11 at 21:35
add comment

1 Answer

In the Command menu, choose TeXing Options and uncheck Generate PDF; the keyboard combination is

Control+C Control+T Control+P

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.