Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a paper using the llncs style (Springer lecture notes for computer science). Using the default formatting, the distance between and the caption and the caption and the table is very big, 16 resp. 9 mm onscreen:

enter image description here

The setting shouldn't be like that. Their own example of a text set in the llncs style (using Word) has a much shorter distance. The proceedings of the same conference from previous years are in the same style, and they all have the short distance. My professor, who is on the program committee, agrees that it should have the short distance. Below, the distance from their own example:

enter image description here

I tried reducing the space above and below the caption using the commands

\addtolength{\belowcaptionskip}{-5pt}
\addtolength{\abovecaptionskip}{-12pt}

but nothing changed at all. Even if I set the distance to ridiculous -100mm, there is absolutely no change to the way my captions look. Using \setlength instead of \addtolength doesn't help. When I use article instead of llncs as a document style, the commands work just as intended. So it must be a setting in the llncs package. How do I override the setting, without changing the llncs package?

An example for the preamble and a table would be:

\documentclass{llncs}
\usepackage{array}
\usepackage{colortbl}
\usepackage{rotating}
\usepackage{placeins}

\setcounter{secnumdepth}{3}
\addtolength{\textfloatsep}{-3mm}
\addtolength{\belowcaptionskip}{-100pt}
\addtolength{\abovecaptionskip}{-100pt}

\begin{document}
This is some filler text representing 
a paragraph above the table
\begin{table}[!htb]
     \caption{Examples for requirement the target users preferred}
     \label{tab:features_liked}
     \begin{center}
             \begin{tabular}{|p{90mm} | p{30mm}|}
             \hline
             Requirement & Relevant value \\
             \hline 
             Some requirement & A value \\
             \hline
             Another requirement & Another value \\
             \hline
         \end{tabular}
     \end{center}
\end{table}
\end{document}
share|improve this question

2 Answers 2

up vote 8 down vote accepted

Further to @egreg's answer, the center environment adds the additional vertical space around your tabular, causing the visually large gap, hence the suggestion to use \centering. Also, the llncs document class executes

\renewenvironment{table}
  {\setlength\abovecaptionskip{0\p@}%
   \setlength\belowcaptionskip{10\p@}%
   \@float{table}}
  {\end@float}

which removes \abovecaptionskip and fixes \belowcaptionskip to 10pt at every use of table (actually, it does the same for table*). If you wish to remove this restriction altogether, and perhaps have more freedom over your caption spacing, you have the following choices:

  • manual assignment of these lengths inside the environment (table or table*), immediately after \begin{...} or before \caption[..]{...}; or
  • automatic removal (or modification) these the length restriction by means of the etoolbox package. For this use

    \usepackage{etoolbox}% http://ctan.org/pkg/etoolbox
    ...
    \makeatletter
    \patchcmd{\table}{0\p@}{5\p@}{}{}% \abovecaptionskip @ 0pt -> 5pt
    \patchcmd{\table}{10\p@}{5\p@}{}{}% \belowcaptionskip @ 10pt -> 5pt
    \makeatother
    

    which patches the beginning of the table environment. The command \patchcmd has the format \patchcmd{<command>}{<search>}{<replace>}{<success>}{<failure>} that searches for <search> in <command> and replaces it with <replace>. Additionally, it executes <success> if this patch was successful, and <failure> if not. Since the patch works, there's need to bother with <success> or <failure>, hence they are both left empty {}. The modification to 5pt was arbitrary and can be adjusted to your liking. This is, of course, dependent on whether article submissions allow such modifications in the first place.

share|improve this answer

There are two aspects of the problem.

First the main one: don't use the center environment for centering the table, but rather \centering.

\begin{table}[!htb]
\centering
\caption{Examples for requirement the target users preferred}
\label{tab:features_liked}
\begin{tabular}{|p{90mm} | p{30mm}|}
...
\end{tabular}
\end{table}

Second. The llncs class sets the \belowcaptionskip when doing \begin{table}, so a previous setting in the preamble will be ignored. However, this setting is to 10pt, which is reasonable.

So, don't use center.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.