Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the latest version of latexmk (4.26) installed on Mac OS X 10.7.1. I often get the following message (basically, for all references in the text) on compiling via latexmk -pvc -pdf:

Package biblatex Warning: Value out of range
(biblatex)                at entry 'foo' on input 
line bar.

Has anyone seen this before and knows what goes wrong? A similar question was posted here https://groups.google.com/group/comp.text.tex/browse_thread/thread/5a2a0d7ab113a151?hl=de (see last post), but was not answered yet. The key "foo" is related to a valid entry in the .bib file and the .bib file is also found (so these two sources of errors are ruled out).

*EDIT: Here is a minimal example *

% (1) Compile with latexmk minimal.tex
% (2) I had the latest version: Latexmk, John Collins, 9 August 2011. Version 4.26
% (3) My latex distribution is: TeXLive-2011 v. 2.0 (Build 150) installed via the latest MacTeX distribution. 
% (4) I work on Mac OS X 10.7.2
% Note: I used latexmk and biblatex on 10.6 with TeXLive-2010 for quite some time (also with DeclareFieldFormat{labelyear}) without flaws 

\documentclass{scrartcl}

\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[american]{babel}
\usepackage[
style=authoryear,
uniquename=false,
hyperref=true,
maxnames=2,
date=short
]{biblatex}

\DeclareFieldFormat{labelyear}{\mknumalph{#1}} % => comment this out and it works!

\usepackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{mykey,
author={TeX, L.},
journal={Journal of LaTeX questions},
pages={1--10},
title={{Minimal title}},
volume={1},
number={1},
year={2011}}
\end{filecontents}

\bibliography{mybib}

\begin{document} 
Some text
\par\bigskip
\textcite{mykey}
\par\bigskip
Some more text
\printbibliography 
\end{document}
share|improve this question
    
It's difficult to say without more information about the version of MacTeX you have on your machine. That message is from February 2010 and biblatex has been updated many times since then. –  egreg Oct 11 '11 at 22:07
    
Thanks for helping. I use MacTeX 2011 (very latest TeXLive 2011 version for Intel 64; v. 2.0 (Build 150)). So shall I update biblatex? –  Marius Hofert Oct 11 '11 at 22:26
3  
The first thing to do is certainly to run TeX Live Utility in order to update TeX Live. Then retry. If the problem persists, please try and write here a minimal example showing it. –  egreg Oct 11 '11 at 22:30
1  
Looking at the code the warning seems to be issued if you try to output a number larger than 26 with a char (alphabetically). But without an example it is impossible to say which number is affected (and if the warning is correct or a bug). –  Ulrike Fischer Oct 12 '11 at 10:08
    
Dear Ulrike, Dear egreg, I added a minimal example above. As explained, I have the very latest installation of all pieces (TeXLive, latexmk), so an update is most likely not a solution. Cheers, Marius. –  Marius Hofert Oct 13 '11 at 8:20
add comment

1 Answer

From biblatex doc:

\mknumalph{⟨integer⟩}
Takes an integer in the range 1–702 as its argument and converts it to a string as follows: 1=a, ... , 26=z, 27=aa, . . . , 702=zz. This is intended for use in formatting directives for the extrayear and extraalpha fields.

When you apply it to the year label, you go out of range. That command must be applied to extrayear or extraalpha field for distinguishing among different items published in the same year, not the the year field: you probably don't want to print the year in alphabetical representation.

share|improve this answer
    
Dear egreg, thanks for helping. My intention was simply to remove the (default-)italics from the year label if there is more than one publication of the same authors in the same year. Do you know how to achieve that (with style=authoryear)? I used this for quite some time now in many different documents and it always worked... hmmm... –  Marius Hofert Oct 13 '11 at 8:58
    
With settings as in the example I don't see any italics –  egreg Oct 13 '11 at 10:58
    
okay, I just checked the original example I was working on (containing much more settings than the minimal example above) and it also contained no italics. Maybe that came from an older version, I'm pretty sure I put this line in for a good reason back then. Good to know, thanks very much! –  Marius Hofert Oct 13 '11 at 11:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.