Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having the same problem as described here (i.e., I get unwanted URLs, DOIs, etc showing up in my reference section): Biblatex: Get rid of ISSN, URLs and DOIs in references

Two caveats:

  1. I am rather new to LaTeX so I don't understand the solution mentioned in the above link. Where should I use the options doi=false,isbn=false,url=false? What is "the manual" referred to in the solution? Could someone perhaps explain this more fully?
  2. I don't know if my particular installation of tex and use of bibtex (not biblatex) would affect the solution.

I have a default installation of TeX Live 2011 (obtained from the CTAN website). I edit and compile tex documents using vim and vim-latexsuite. The bibliography style files I would like to use is named "unsrtnat". The only thing I have in my preamble that I think might possibly affect the citations is the line: \usepackage[square,comma,numbers,sort&compress]{natbib}


I didn't see anything in a FAQ about how to continue the dialogue so here it goes....

@lockstep: thanks for the prompt reply. What you say makes sense but something is still not working. It is probably something to do with my installation/configuration. But let's deal with the easier to diagnose problem first - a problem in the .tex or .bib file.

Here is my test script named "simple_example.tex"

\documentclass[a4paper,12pt]{article}
\usepackage[style=numeric-comp,doi=false]{biblatex}
\title{Here is the title.}
\author{ John S. Doe }
\begin{document}
\maketitle
\begin{abstract}
    Blah blah blah-blah blah.
\end{abstract}
\section{Introduction}
    Blah blah blah-blah blah \cite{AD_Smith2010}.
    Blah blah blah-blah blah.
\end{document}

And here is the .bib file:

% This file was created with JabRef 2.6.
% Encoding: ISO8859_1
@ARTICLE{AD_Smith2001,
author = {Arthur D. Smith},
title = {A simple model of LaTeX References.},
journal = {Journal of LaTeX},
year = {2001},
volume = {100},
pages = {1-10},
number = {3},
keywords = {LaTeX models; biology},
doi = {10.1115/1.1372322},
owner = {me},
publisher = {Cambridge},
timestamp = {2011.04.01},
url = {http://link.aip.org/link/?PBY/321}
}

@comment{jabref-meta: selector_publisher:}
@comment{jabref-meta: selector_author:}
@comment{jabref-meta: selector_journal:}
@comment{jabref-meta: selector_keywords:}

Assuming that the above code is sound, what terminal commands would be necessary to compile the tex file and generate a pdf? Until yesterday, I used Tex Live 2009 from the Ubuntu repos and I would do something like: pdflatex, biblatex, pdflatex, pdflatex. Now that I have Tex Live 2011 installed I get an error message: biblatex command not found.

share|improve this question
    
Welcome to TeX.sx! A tip: You can use backticks ` to mark your inline code as I did in my edit. –  doncherry Oct 12 '11 at 22:25
    
The "correct" way to continue the dialogue is to edit your question to add more detail. I think this only works if you register your account, though (which is highly recommended for active participation). We should probably add this to the FAQ, thanks for the pointer! –  Jake Oct 13 '11 at 1:07
    
@Bob: In addition to what Jake says, we like to keep each question focussed on one issue. Now, in this case you probably need the answers on several things at once to get anywhere, so that's fine, but where possible it's best to ask a series of focussed questions and link them if necesary. –  Joseph Wright Oct 13 '11 at 6:04
    
@Bob: Your first unregistered account expired and your second post was then posted under a new, but almost identical looking account. I merged both accounts together now so that you can edit your question again. Please consider registering your account fully to avoid this in the future. I also moved your second post, and the comments below it, to the question. –  Martin Scharrer Oct 13 '11 at 7:17
add comment

2 Answers

up vote 1 down vote accepted

The example in the updated answer misses a couple of details: you have to announce what .bib file(s) to search in; moreover you somewhere have to tell LaTeX where to print the bibliography:

\documentclass[a4paper,12pt]{article}
\usepackage[style=numeric-comp,doi=false]{biblatex}
\bibliography{bob}

\title{Here is the title.}
\author{John S. Doe}
\begin{document}
\maketitle
\begin{abstract}
    Blah blah blah-blah blah.
\end{abstract}
\section{Introduction}
    Blah blah blah-blah blah \cite{AD_Smith2001}.
    Blah blah blah-blah blah.

\printbibliography
\end{document}

Here's where biblatex differs from the usual way: the \bibliography command (or the more modern \addbibresource) should go in the preamble, while the bibliography is printed by \printbibliography.

The command to run for checking the references with the database is

bibtex bob

(if bob.tex is your main file) or

biber bob

but this one requires also backend=biber in the options to biblatex.

Add url=false to the options given to biblatex if you don't want the URL to be printed.

share|improve this answer
    
Got it. This is the greatest thing since the invention of sliced bread. –  Bob Alexander Oct 13 '11 at 12:11
add comment

Ad 1: These are package options, i.e., your document preamble would include a line like

\usepackage[style=<somebiblatexstyle>,doi=false,isbn=false,url=false]{biblatex}

Ad 2: TeX Live 2011 includes all you need to use biblatex. However biblatex is a replacement for (among other packages) natbib. Instead of using natbib and its unsrtnat bibstyle, you would say \usepackage[style=numeric-comp,sorting=none]{biblatex}. (It is likely that the formatting will be somewhat different by default.)

See also What to do to switch to biblatex?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.