Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I’m the author of musuos.cls and while writing a paper with it I noticed that the dblfnote-package leads to unbalanced footnote columns

enter image description here You can see that the left colum has one line less than the right one but I’d expect that it is the other way around.

This is the MWE

\documentclass[
    twocolfnotes,
]{musuos}

%% class option or this code (which is activated by the options)
%% cause the problem
%\usepackage{dblfnote}
%\setlength{\DFNcolumnsep}{2em}
%\setkomafont{footnote}{\scriptsize}

\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}

\usepackage[ngerman]{babel}
\usepackage{blindtext}
\begin{document}
\Blindtext[2]
\footnote{Vgl. Frank Hentschel: Das Ewig-Weibliche --
    Listz, Mahler und das bürgerliche Frauenbild. In:
    Archiv für Musikwissenschaft 51.4 (1994), S. 274--293, S.286.}
\footnote{Vergleiche S. 4 und Notenbeispiel 4.}
\blindtext[3]
\end{document}

I can’t find out why this problem occours …

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

It seems you set \widowpenalty=10000 in your class, and this penalty also applies to dblfnotes footnotes. Resetting the penalty to its LaTeX default value of 150 corrects the "problematic" column break. You could also use the etoolbox package to patch the \footnote command and reset widowpenalty only for footnotes.

\documentclass[
    twocolfnotes,
]{musuos}

%% class option or this code (which is activated by the options)
%% cause the problem
%\usepackage{dblfnote}
%\setlength{\DFNcolumnsep}{2em}
%\setkomafont{footnote}{\scriptsize}

\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}

\usepackage[ngerman]{babel}
\usepackage{blindtext}

\usepackage{etoolbox}
\pretocmd{\footnote}{%
  \widowpenalty=150% LaTeX default value
}{}{}

\begin{document}
\the\widowpenalty

\Blindtext[2]
\footnote{Vgl. Frank Hentschel: Das Ewig-Weibliche --
    Listz, Mahler und das bürgerliche Frauenbild. In:
    Archiv für Musikwissenschaft 51.4 (1994), S. 274--293, S.286.}
\footnote{Vergleiche S. 4 und Notenbeispiel 4.}
\blindtext[3]
\end{document}
share|improve this answer
    
Seems to work, thank you very much! I’d never guessed that … –  Tobi Oct 14 '11 at 15:58
add comment

If you want to change the value of \widowpenalty in the footnotes only, you can say

\patchcmd{\@footnotetext}{\dfn@latex@footnotetext{#1}}
  {\dfn@latex@footnotetext{\widowpenalty150 #1}}{}{}

after having loaded dblfnote (requires etoolbox).

Note also that the setting \clubpenalty in your class is not correct, as LaTeX changes the value of this parameter in some situations and reinstates it by looking at the value of \@clubpenalty; so

\clubpenalty=5000  % initial value
\@clubpenalty=5000 % for reinstating it

is the right way to go.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.