Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a quite wide table in my document, that I would like to display "rotated". Everything seems fine, but apparently there is some problem towards the end: when I try to print out (print to file) I get the rotated page upside down.

Is there a way to solve the issue?

(Latex->dvi2ps->ps2pdf->View PDF (I use Texmaker))

\documentclass[twoside,openright]{report}
\usepackage[]{rotating}
\usepackage[]{fancyhdr}

\fancyhead[RE,LO]{\fancyplain{}{\textbf{\textit{\leftmark}}}}
\fancyhead[LE,RO]{\fancyplain{}{\textbf{\thepage}}}
\fancyfoot[]{}

\pagestyle{fancyplain}

\begin{document}
Normal page.
\clearpage
\begin{sidewaystable}
\begin{tabular}{|c|c|c|c|}
\hline \textbf{Bla Bla Bla} & 01/01/2009 & 01/01/2010 & \\ 
\hline \textbf{Abcd efc} & Something something & Little bit longer description for something.\\ 
\hline 
\end{tabular} 
\caption{Something.}
\end{sidewaystable}
\clearpage
Another normal page.

\end{document}
share|improve this question
    
It is standard for the sidewaystable to rotate the table by 90 degrees. However, it could be a setting on your printer when duplexing? If you create a 3-page document without the sidewaystable, does the second page still get printed upside down? I say printer, but I think it would be the same if you were to "save to file." –  Werner Oct 15 '11 at 15:50
    
Thanks for your answer. If I try a "print to file" operation on any other three pages of my document, I get them with the correct orientation. In some way the page is like a landscape in PDF and this creates some problems. Is there a way to rotate only the table, while keeping the page with its normal, portrait orientation? Since I will not be there when they print it, I don't want my "book" to have an upside down page :) –  Danilo Oct 15 '11 at 16:01
    
You should compile your document directly to PDF using pdflatex, as opposed to latex -> dvips -> ps2pdf. Does this solve your problem? –  Werner Oct 15 '11 at 17:17
    
1. something.\\ misses a ` & ` : something. & \\ 2. Directly pdflatex-ing your code (TeXLive 2011) does not rotate the page. Could you try that? –  Stephen Oct 15 '11 at 17:26
    
I guess it would work, since already two of you suggested it! Anyway I modified the ps2pdf call as suggested by Werner since I have many eps files. Thanks! –  Danilo Oct 16 '11 at 8:37

1 Answer 1

up vote 7 down vote accepted

You have two options to fix this behaviour.

  1. ps2pdf automatically rotates landscape-like pages during processing. Since that is the case with your sidewaystable page, this page is rotated in the display, and subsequently in print as well. Supplying the option distiller option -dAutoRotatePages=/None to Ghostscript should leave the landscape pages in their original portrait orientation.

  2. Use pdflatex directly. This circumvents the above requirement all together.

share|improve this answer
    
Since my document is full of eps images, I will go for the first option. I just changed the command invoked by TexMaker for the ps2pdf instruction and everything seems to work fine. Thank you Werner and thank to the others, too! –  Danilo Oct 16 '11 at 8:35
    
If you use TeXLive 2011 (and maybe 2010 too) pdflatex convert all your .eps files in .pdf files on-the-fly during compilation. So you would be able to use it. Another way is to convert the images on your own using epstopdf. –  Spike Oct 16 '11 at 13:35
    
@Spike: I don't think conversion is done on-the-fly. Mind you, I've always gone the route of converting from (E)PS to PDF before compiling with pdflatex. –  Werner Oct 16 '11 at 16:22
    
@Werner I don't know if my explanation was clear but I meant exactly what you can read here (first section): tug.org/TUGboat/tb31-2/tb98berry.pdf As you can read, the conversion is made by pdflatex itself during compilation –  Spike Oct 16 '11 at 19:39
    
@Spike: I see. Thanks for the reference. –  Werner Oct 16 '11 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.