Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have found How to configure kile to run texlive 2011? and this is my problem.

I have installed Ubuntu's TeXLive with sudo apt-get install texlive and TeXLive 2011 using the net installer from CTAN (There says there is no problem have both installations). I tried latex -v and I found

pdfTeX 3.1415926-1.40.10-2.2 (TeX Live 2009/Debian)
kpathsea version 5.0.0
Copyright 2009 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.2.42; using libpng 1.2.42
Compiled with zlib 1.2.3.3; using zlib 1.2.3.3
Compiled with poppler version 0.12.4

and did put the following script as zzzz-texlive.sh into the directory /etc/profile.d/:

export PATH=/usr/local/texlive/2011/bin/`uname -i`-linux:$PATH
export MANPATH=/usr/local/texlive/2011/texmf/doc/man:$MANPATH
export INFOPATH=/usr/local/texlive/2011/texmf/doc/info:$INFOPATH
unset TEXINPUTS
unset TEXMFCONFIG

and restarted the system.

As explain in by the net installer, restarted the system but latex -v says TeX Live 2009/Debian like in the first time.

So, I think I'm not using TeX Live 2011.

How can I use this TeX Live packages in my Ubuntu 10.04 LTS?

share|improve this question
1  
    
What does echo $PATH print in the terminal? Does it include the TL 2011 path? Your zzzz-texlive.sh script might not be executed for some reason. Check if it is readable for all (chmod +r zzzz-texlive.sh to make it so). –  Martin Scharrer Oct 17 '11 at 19:52
1  
My uname -i returns unknown... so the scripts works wrong...how should I put the hardware plataform? (I have a Ubuntu 10.04 LTS amd64 2.6.32-33-generic)... –  GarouDan Oct 17 '11 at 23:59
    
I have installed TeX Live with the net install as says in How to install “vanilla” TeXLive on Debian or Ubuntu? –  GarouDan Oct 18 '11 at 0:05
add comment

2 Answers

up vote 2 down vote accepted

It's quite strange that uname -i gives "unknown". However, the TeX Live installer should have guessed your architecture. So, look at the output of

ls /usr/local/texlive/2011/bin

and use that; since you're on a 64 bit machine, it should be

x86_64-linux

so the first line to be saved in zzzz-texlive.sh should be

export PATH=/usr/local/texlive/2011/bin/x86_64-linux:$PATH

A logout-login cycle should be sufficient to make the new setting work.

share|improve this answer
    
Thx! Worked. latex -v returned pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011) –  GarouDan Oct 18 '11 at 10:14
add comment

After installing TeXLive2011 type in your case (Ubuntu 64 bits),

$gedit ~/.profile

and type in the file

PATH=/usr/local/texlive/2011/bin/x86_64-linux:$PATH; export PATH MANPATH=/usr/local/texlive/2011/texmf/doc/man:$MANPATH; export MANPATH INFOPATH=/usr/local/texlive/2011/texmf/doc/info:$INFOPATH; export INFOPATH

and restart. Tell me if it worked.

share|improve this answer
    
Thx too @Regis da Silva! –  GarouDan Oct 18 '11 at 10:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.