Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My question is nearly identical to that posed in these:

Where do I place my own .sty files, to make them available to all my .tex files?

How to have local package overide default package

LaTeX fails to find my .sty file

but unfortunately, I've followed the instructions in various ways and LaTeX still doesn't find my .bst file UNLESS it is in ./ (the PWD). I've tried 3 approaches:

  1. export TEXINPUTS=.:~/my/path: (attempted with both ~ and the full-path)
  2. put the file in ~/Library/texmf/ (I'm on a mac)
  3. specified the full path to the .bst file in the \bibliographystyle command

Any ideas what I'm still doing wrong? I've tried texhash (even though it's not supposed to be necessary) and that also failed. The fact that it works if I put the file in the same directory as the .tex file says it's not a problem with the .bst.

share|improve this question
2  
The relevant variable is BIBINPUTS (like TEXINPUTS doesn't need to be set in the shell); its usual value expects a well structured tree in the "personal area"; so ~/Library/texmf/bibtex/bst is the right place. –  egreg Oct 17 '11 at 23:43
1  
@egreg: Actually it is BSTINPUTS, isn't it? AFAIK BIBINPUTS is where bibtex/biber look for databases (.bib-files). –  Daniel Oct 27 '11 at 7:34
    
@Daniel Yes, it's BSTINPUTS –  egreg Oct 27 '11 at 7:38
add comment

1 Answer

up vote 9 down vote accepted

According to this link related to TexShop and Mac:

How to Install Style and BiBTeX Style files

Create the following folder ~/Library/texmf/tex/latex/misc
Place any style files (*.sty) in this folder.
Create the following folder ~/Library/texmf/bibtex/bst
Place any BiBTeX style files (*.bst) in this folder.

Where should I put my bibliographic database files?

Create the following folder ~/Library/texmf/bibtex/bib
Place any bibliographic database files (*.bib) in this folder.
share|improve this answer
    
Thanks. Do you have any idea why the "standard" ways of doing this do not work? i.e., why does TexShop (apparently) fail to respect TEXINPUTS? –  keflavich Oct 17 '11 at 23:28
    
Don't know for sure, but I think it not TeXShop. TeXShop just calls latex and 'bibtex` and its those programs that need to be able to locate the files. So, if bibtex does not use the TEXINPUTS path for search, there is not much TeXShop can do about it. –  Peter Grill Oct 17 '11 at 23:31
    
hmm, ok, but it looks like latex, not just bibtex, is looking in the wrong spots. If it's not just TeXShop, I wonder why other Mac users seem not to have had the same issue I did? Or perhaps they did and I've just been reading nix/windows users' posts –  keflavich Oct 17 '11 at 23:34
    
@keflavich: Have you tried setting the variables in a bash shell and then start TexShop from there? Also note that the right variable to set here is BSTINPUTS, not TEXINPUTS, which might also be the reason TexShop apparently does not respect it (see comments on the question above). –  Daniel Oct 27 '11 at 7:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.