Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using MikTeX 2.9 and compiling "hello.tex" containing:

\documentclass{minimal}

\begin{document}
text
\end{document}

with:

xelatex --synctex=1 --aux-directory=auxdir hello.tex

produces a E:\something.synctex.gz instead of hello.synctex.gz in the same directory with the source hello.tex. In particular, "something" is the same length as "hellow.tex", indicating that SyncTeX is fed with the wrong path. This problem does not arise if pdflatex is called instead.

I have been using this command for a long time without any problems, but after updating my distribution the previous problem arose.

Any help will be much appreciated. If it turns out to be a bug, please tell me to which bug list I should report it.

share|improve this question

closed as too localized by Joseph Wright Mar 3 '12 at 21:48

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
It is a bug and I made a bug report: sourceforge.net/tracker/… –  Ulrike Fischer Oct 18 '11 at 11:15
1  
Thank you, by the way I have updated again from yesterday and the more recent version of miktex-xetex-bin-2.9 still has the bug, although it now places the .synctex.gz file in the same directory. This allows a temporary workaround for anyone using a makefile to compile, issue rm ./*.synctex.gz, then xelatex whatever and finally cp ./*.synctex.gz $(main_file).synctex.gz, where $(main_file) is your .tex filename. This is a temporary work-around until the bug gets fixed. –  johntex Oct 18 '11 at 11:56
    
After the previous work-around, it turns out that the generated .synctex.gz is not properly aligned with the source tex. It is offset by a line and this remains even when not using the --aux-directory option. –  johntex Oct 18 '11 at 12:29
    
Update from the buglist: the bug concerning the SyncTeX file name and placement has been fixed and will be available with the next update cycle of MikTeX. It remains to see whether the mismatched alignment issue between .pdf and .tex will remain. –  johntex Oct 18 '11 at 12:56
    
If not: you know now where to make bug reports. (I'm not using synctex and so can't test problems.). –  Ulrike Fischer Oct 18 '11 at 13:12