Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have Ubuntu 10.04 and I have installed Tex Live 2011 (as super user) as per quick install guide. I also have run the command sudo texhash.

I use Texworks to make PDFs. But I get error when trying to load most basic font packages, like helvet or times. I use this command in the pre-amble of the tex document:

\usepackage[T1]{fontenc}
\usepackage{times}

or any other name for font, like helvet or cmbright.

I get the error that the sty package cannot be loaded:

This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
entering extended mode
(./letterToPresident.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, loaded.
(/usr/share/texmf-texlive/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texmf-texlive/tex/latex/base/size11.clo))
(/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
(/usr/share/texmf-texlive/tex/latex/base/t1enc.def))

! LaTeX Error: File `cmbright.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Is there any way to get a list of font packages THAT CAN BE LOADED using \usepackage command?

share|improve this question
2  
You seem to have a very basic TeX installation. Check with the package manager or do the big step and install TeX Live 2011 –  egreg Oct 18 '11 at 22:49
1  
Your log shows that TeXworks is picking up TeX Live 2009, installed by its package manager. Try running tex -v from the Terminal to see which TeX is being picked up, and if this is correct check your TeXworks preferences to make sure it's using the correct one. –  Joseph Wright Oct 19 '11 at 9:03
add comment

1 Answer

Thanks egreg and Joseph.

Apparently I forgot to add the Tex Live 2011 bin directory to the environment variable $PATH:

PATH=/usr/local/texlive/2011/bin/i386-linux:$PATH

As a one-time fix it can be directly typed in the terminal. But it would be required again after every reboot (complained about here: Linux forgets TeXlive2011 paths upon restart).

A permanent solution that automatically updates the path accordingly is shown here: Setting the path to textlive installation, round 2

Now everything works!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.