Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following this ordeal: Compounds defined implicitly in captions (chemscheme/chemstyle/chemcompounds)

I completely removed TeX and installed MacTeX 2011. My document now compiles, but every number in every scheme is missing (replaced with the usual ? symbol). There are no obvious errors relating to this in the console, apart from:

<Thesis-pics.pdf, id=2, page=1, 162.6075pt x 150.5625pt>
<use Thesis-pics.pdf, page 1> [1
Non-PDF special ignored!
Non-PDF special ignored!{/usr/local/texlive/2011/texmf-var/fonts/map/pdftex/upd
map/pdftex.map} <./Thesis-pics.pdf>]

near the top. (The chemstyle package uses epstopdf to generate pdf images for compilation with pdflatex). Every instance of this error appears to be caused by a different problem...

Edit: compounds referred to in the text work fine...

share|improve this question
    
Just found that it works as expected if I use latex, but this requires removing my (many) .png images. –  JMS Oct 19 '11 at 4:58
    
Solved... explicit [runs=2] option for auto-pst-pdf was necessary. Weird, since this was never the case using the older version. –  JMS Oct 19 '11 at 5:52
2  
You've always needed two LaTeX runs to get the numbering correct. –  Joseph Wright Oct 19 '11 at 8:40
    
Even in my "answer" to your previous question required two runs. Since @Jake encountered a similar problem as you I did not think that the problem was with not running it twice. Again, sorry that you had so much difficulty but at least your problem now appears solved. You should probably post answers to both questions so that they can marked as answered. –  Peter Grill Oct 19 '11 at 22:53
add comment

1 Answer 1

As JMS said, for using with pdfLaTeX the solution was specifying the option [runs=2] for auto-pst-pdf to get two runs for correct numbering:

\usepackage[runs=2]{auto-pst-pdf}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.