Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just upgraded to Ubuntu 11.10 and was trying to get my custom styles/fonts and the like to work. As on all distributions before, I store them in $HOME/texmf, with a tree structure according to the main TEXMF-Folder.

I did run texhash but my system seems unable to find the files in $home/texmf (i.e. kpsewhich "anyfilenameinthatfolder" doesn't return anything). However, using kpsepath, it is apparently listed, e.g. for kpsepath tex it gives:

:!!/home/USERNAME/texmf/tex/

amongst others. kpsewhich -var-value TEXMFHOME returns:

 /home/USERNAME/texmf

So that appears to be correct, too. Finally, I thought that something in my .cnf file is wrong, so I opened /usr/share/texmf/web2c/texmf.cnf and found

TEXMF = {$TEXMFCONFIG,$TEXMFVAR,$TEXMFHOME,$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$TEXMFLOCAL,!!$TEXMFMAIN,!!$TEXMFDIST}

which again seems to be correct. I have no clue what is wrong here, since it used to work fine. Any help would be highly appreciated.

share|improve this question
    
Dunno if this helps but I had problems getting the path to TeX Live's binaries recognized (e.g. tlmgr). The solution for me was to add the path to /etc/profiles by including PATH=/usr/local/texlive/2011/bin/x86_64-linux:$PATH in it. Maybe you can do something similar but for TEXMFHOME? –  N.N. Oct 20 '11 at 16:59
    
That might be the problem. I installed texlive straight from the repos, is tlmgr included in that distribution? I did also try to run texhash texmf and the resulting ls-R file lists all the files in the folder, however is not read by my system. The same happens when I put the files into usr/local/share/texmf - I ran sudo texhash, files aren't recognized altough listed in the respective ls-R. I did follow Herberts suggestions [link] (tex.stackexchange.com/questions/27922/…) - no success. Any ideas of what I should do? –  David Oct 20 '11 at 17:28
    
The TeX Live from the repos is the 2009/Debian one and has not tlmgr. The problem might be in a ls-R file in ~/texmf: if one's there, changes to the tree will not be seen (and the file will not be regenerated by texhash). If it's there, delete it. –  egreg Oct 20 '11 at 20:36
    
I tried it first without generating a ls-R file. Since it did not work, I used texhash ~/texmf to get a ls-R file in my texmf-folder. Did not work, too, so I deleted it, still the same problem. Tex does not seem to update its files when I ran texhash or mktexslr. Even files in usr/local/share/texmf are not found! –  David Oct 20 '11 at 21:17
1  
I fixed the problem by removing the debian version of texlive and just installing texlive manually. I set the path and everything worked smoothly. This might be the preferred solution anyway since texlive in the repos is - as it seems - fairly outdated. Thanks for your help! –  David Oct 24 '11 at 9:15

2 Answers 2

A community wiki answer, based on the OP David's comments.

The solution, which worked for the OP and is recommended by him: don't use (or perhaps deinstall) the older Ubuntu/Debian repository version and install an up-to-date version of TeXLive, which also works on Ubuntu/Debian. Additionally it has the advantage that you can use the TeXLive Manager tlmgr for installing the most recent updates.

Source for download and installation: http://www.tug.org/texlive/

share|improve this answer
    
note that the tug.org address (very properly) only gives you a loader; the loader takes its stuff from mirror.ctan.org, which is a distributed object and hence avoids all the load going to one site (terabytes/day tend to make one look around uneasily in case the accountants are looking over your shoulder). –  wasteofspace Mar 4 '12 at 0:34
1  
I have the OP's problem with a 'manual' TeXLive installation, not the Ubuntu repo version. –  a different ben Oct 11 '13 at 6:51

I ran into the very same problem on Linux Mint Debian Edition (LMDE) Update Pack 6. It may seem a bit odd, but the solution is as simple as running texhash ~/texmf; i.e. with ~/texmf as a directory argument and without sudo in front. However, be sure to mimic the proper TEXMF directory structure in ~/texmf for all to work well.

By the way, doing so saves you from uninstalling and reinstalling TeXLive outside the package manager which also carries its problems; Other packages that depend on TeXLive would be removed as well. Dummy packages would need to be installed to trick the package manager and then those dependent packages would need to be reinstalled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.