Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I created a BibTex database for the references for my document. The abc.bib which resides in the same directory as .tex file resides.

     @conference{ref1,
     author  = {Chris H. Q. Ding and Xiaofeng He and Hangyuan Zha},
     title   = {A spectral method to separate disconnected and nearly-disconnected web graph componenets},
     booktitle = {KDD},
     year    = 2001
     }

and i have embedded following code in the .tex file.

    \bibliographystyle{plane}
    \bibliography{abc}
    \end{document}

I am using kile to compile and run the command Build->quickBuild and i get the following error. Moreover i don't get any citation in my report. Instead i see inverted ?.What can be the reason for it?

[EDIT]

One thing i forget to mentioned here is , i am getting following error message:

 [BibTex]thesis.aur => thesis.bbl(bibtex)
 [BibTex] finished with exit code 2

and the package inclusion is :

\documentclass{report}
\usepackage[english]{babel}
\usepackage{amsmath}
\usepackage{algorithmic}
\usepackage{algorithm}
\usepackage[all]{xy}
share|improve this question
1  
Did you run latex again after compiling the bibliography? You need to run latex twice to get the references correctly. The general idea is: latex -> bibtex -> latex. Also, I try your example; if you fix the typo "plain" instead of "plane" it works. –  adn Oct 24 '11 at 12:12
    
Please provide a full compilable MWE that illustrates the problem including the \documentclass so that those trying to help don't have to recreate it. –  Peter Grill Oct 24 '11 at 17:17
add comment

migrated from stackoverflow.com Oct 24 '11 at 11:18

This question came from our site for professional and enthusiast programmers.

4 Answers

I think you have a typo. It should be \bibliographystyle{plain} not plane.

share|improve this answer
    
ya that was the typo.Thanks for pointing it, I tested it after correcting even i am getting the same problem. –  thetna Oct 23 '11 at 17:37
add comment

I haven't used Kile, but you should make sure that the Quickbuild you are executing includes running the command bibtex as well. See for help:

http://kile.sourceforge.net/showscreenshot.php?id=12

Make sure you run the latex command, then the bibtex and the a couple more times the latex again.

One last thing that I noticed, but I'm not sure if this is mandatory to change, is the year 2001 in your .bib file should be within curly brackets {}.

share|improve this answer
    
There are several options on what Kile's QuickBuild will do. The default one is set to "PDFLaTeX+ViewPDF". –  Nikos Alexandris Oct 9 '12 at 22:02
add comment

I use Kile, and I also has this error reported all the time. But my references can get into the PDF correctly all the time regardless of this error. What I do is whenever I want to embed a new reference, I will run: PDFLaTeX --> BibTeX --> PDFLaTeX.

Hope it helps.

share|improve this answer
    
Welcome to TeX.sx! –  Peter Jansson Mar 4 '13 at 20:00
add comment

If you had more than this entry: Check your citations in file abc.bib for any missing deliminators , or a }. To run bibtex in the console might give you some more hints.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.