Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How do I get rid of all underlines under links in hyperref? I am processing to DVI, not PDF (because I am using some PS-specific graphing which is non-functional in pdflatex). I am specifying

\usepackage[svgnames]{xcolor}
\usepackage{hyperref}
...
\hypersetup{linkcolor=MediumSlateBlue,urlcolor=Olive,
 colorlinks=true,linkbordercolor=Red,citebordercolor=Red, 
 filebordercolor=Red,runbordercolor=Red,menubordercolor=Red}

using Red to try to see what changes what, to work out what to type, but all my ToC and other links are still underlined in 100% blue (the text of links is correctly in MediumSlateBlue).

How do I turn off all underlining? All the pages I can find are about turning it on, and the manual doesn't appear to mention underlining (it talks about "borders" — is this an artifact of using regular latex rather then pdflatex?)

share|improve this question

1 Answer 1

It's a feature of xdvi; you can disable underlining by calling

xdvi -linkstyle 0 filename

From the man page:

-linkstyle
        (.LinkStyle)  Determines the style in which hyperlinks are displayed. Possi-
        ble values and their meanings are:

         0       No highlighting of links
         1       Underline links with link color
         2       No underlining, color text with link color
         3       Underline and display text colored with link color

        The values for link color are specified by the options/resources  -linkcolor
        and -visitedlinkcolor (which see).
share|improve this answer
    
Oww. That's something I didn't expect. Thanks for pointing this out. I gave up using xdvi years ago — I'm using kdvi and it doesn't seem to have a similar option. xdvi's interface is rather primitive compared with kdvi. At least Okular seems to render the links as required (although its interface sucks as well, with all that space wasted on the LH side by a useless icon bar). –  Peter Flynn Oct 25 '11 at 22:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.