Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

AMSMath manual states that

(1) "sumlimits (default) Place the subscripts and superscripts of summation symbols above and below, in displayed equations."

(2) "intlimits Like sumlimits, but for integral symbols."

(3) "To use one of these package options, put the option name in the optional argument of the \usepackage command—e.g., \usepackage[intlimits]{amsmath}."

There are two problems.

(1) Apparently, there is some "option clash" when I use the amsart document class.

\documentclass[11pt]{amsart}
\usepackage[intlimits]{amsmath}
\begin{document}
\(\int_0^3xdx\)
\end{document} 

!LaTeX Error: Option clash for package amsmath

(2) There is no "clash" with the article document class. But the output does not agree with the stated outcome of the manual.

\documentclass[11pt]{article}
\usepackage[intlimits]{amsmath}
\begin{document}
\(\int_0^3xdx\)
\end{document}

enter image description here

This must be a known problem. However, I could not find any reference to it at Tex.SX.

share|improve this question

2 Answers 2

up vote 7 down vote accepted

You wrote:

There are two problems:

(1) Apparently, there is some "option clash" when I use the amsart document class.

The reason there's an "option clash" is that the amsmath package is already loaded by the amsart document class; hence, it shouldn't be loaded a second time with options that weren't already specified the first time the package was loaded (in the present case, at the \documentclass stage). To activate the options nosumlimits and intlimits, you must load them via the \documentclass command:

\documentclass[nosumlimits,intlimits]{amsart}

(2) There is no "clash" with the article document class. But the output does not agree with the stated outcome of the manual.

Recall that TeX has two math styles: "text style", also called "inline style", and "display style". The following MWE illustrates (i) the differences in the sizes of the integral signs in the two math styles and (ii) the effects that the commands \int\limits and \int\nolimits have in each of the two styles. Observe that the amsmath package is loaded with the intlimits option. As you can see from the ouput of this code, when in inline math style one must state \int\limits explicily in order to get the limits set below/above the integral symbol even if the intlimits option was specified. Conversely, when in display math style, the limits will always be set below/above the integral sign unless one specifies \int\nolimits.

\documentclass{article}
\usepackage[intlimits]{amsmath}
\usepackage{booktabs,tabularx}
\newcolumntype{C}{X}
\begin{document} 

Package \texttt{amsmath} loaded with \texttt{intlimits} option.

\begin{tabularx}{\textwidth}{@{}l *{3}{>{\raggedright\arraybackslash}X} @{}}
\toprule
Math style
& explicitly require side-set limits
& no explicit directive for positioning of limits
& explicitly require below\slash above limits\\
\midrule
Inline 
& $\int\nolimits_0^1 f(x)\,dx$
& $\int_0^1 f(x)\,dx$
& $\int\limits _0^1 f(x)\,dx$  \\[3ex]
Display
& $\displaystyle \int\nolimits_0^1 f(x)\,dx$
& $\displaystyle \int_0^1 f(x)\,dx$
& $\displaystyle \int\limits _0^1 f(x)\,dx$ \\
\bottomrule
\end{tabularx}
\end{document}

enter image description here

Of course, when in inline math mode, one usually does not want the limits of integration to be typeset below/above the integral symbol, because one generally wants to keep the size of the math expressions compact so that the gaps between successive lines don't become too large. In contrast, in equations that are offset or displayed on a line by themselves, typesetting the limits of integration below and above the integral symbol may be a good choice, especially if the integrand is "large", e.g., if it contains a fractional expression.

share|improve this answer

The intlimits and sumlimits options are related to display environments, and they are irrelevant for in-line formulas.

The clash with amsart can be solved by putting the option in the \documentclass line:

\documentclass[11pt,intlimits]{amsart}

It's not necessary to load amsmath, in this case, because the class loads it automatically.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.