TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It seems that the memoir class automatically avoids numbering subsection headings. Chapter and section titles are numbered, but subsection headings contain only the subsection name, and are not prefixed by the subsection number. Why is this the case, and more importantly, how do I turn subsection numbering back on?

share|improve this question
up vote 35 down vote accepted

The correct way to do this, specifically for memoir, IMO, is to use



  • It's a higher-level command --- \setcounter is somewhere in the bowels of memoir/LaTeX
  • It's semantic --- saying "subsection" is hopelessly more meaningful than saying "2"
  • It's practical --- it persists across \mainmatter
share|improve this answer

The counter secnumdepth controls "[t]he level number of the least significant sectional unit with numbered headings" (Lamport, LaTeX: A document preparation system , p. 176). The memoir class sets secnumdepth to 1 (section), so you should change this to 2 (subsection). Alternatively, you may use the memoir command \setsecnumdepth.


\setcounter{secnumdepth}{2}% alternative A
% \setsecnumdepth{subsection}% alternative B





share|improve this answer
Thanks! I had tried setting that in the preamble, but it hadn't worked -- it turned out that \mainmatter resets secnumdepth. Now that I know what to look for, the memoir documentation states that calling \maxsecnumdepth in the preamble sets the numbering level for \mainmatter. – Rahul Sep 21 '10 at 0:19
Just a minor note. If you want the subsection to appear in the TOC as well, you should issue the \maxtocdepth{subsection} command. – recluze Jan 11 '12 at 3:40

change the secnumdepth, using the \setcounter{secnumdepth}{2} the following table may help.

Command                            Level        Comment
\part{part}                        -1       not in letters
\chapter{chapter}                   0       only books and reports
\section{section}                   1       not in letters
\subsection{subsection}             2       not in letters
\subsubsection{subsubsection}       3       not in letters
\paragraph{paragraph}               4       not in letters
\subparagraph{subparagraph}         5       not in letters
share|improve this answer
memoir has an easier interface such that people do not need to remember those numbers – daleif Oct 18 '12 at 10:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.