Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the nomencl package to write a two columns list of terms I frequently use in my thesis. Everything looks fine except that I don't like that whenever the explanation of a term takes more than one line a small indentation is inserted. What I have now is something that looks like:

MyTerm detailed explanation of my term.
   and here follows the second line.

I'd like to have is so that it looks like:

MyTerm detailed explanation of my term.
and here follows the second line.

Can someone please help me? I've tried to go through the documentation of the package but I couldn't really get much out of it!

share|improve this question
3  
I just built a minimal working example and can not reproduce your problem. I get the behaviour you want straight away. You need to provide an example, stating your document class and possible other packages that may influence indention. How do you switch to twocolumn mode? –  Martin H Nov 1 '11 at 10:03
add comment

2 Answers

In the following example I used print the nomenclature in onecolumn mode and in twocolumn mode. The mode twocolumn is generated in two ways. The first one uses the command \twocolumn and the second one the environment multicols*

\documentclass{article}
\usepackage{multicol}
\usepackage{nomencl}
\makenomenclature
\setlength{\nomlabelwidth}{.20\hsize}
\begin{document}
Text
\nomenclature{WYSIWYG}{Is an acronym for What You See Is What You Get. The term is used in computing to describe a system in which content (text and graphics)}
\printnomenclature
\begin{multicols*}{2}
\printnomenclature
\end{multicols*}
\clearpage
\twocolumn
\printnomenclature
\end{document}

After the correct compilation: pdflatex file.tex makeindex file.nlo -s nomencl.ist -o file.nls pdflatex file.tex

I get the correct output:

enter image description here

enter image description here

share|improve this answer
add comment

If I understand correctly what you're looking for, you need to change the settings of the list environment hard coded in nomencl.sty. But I don't see something that is two-columns specific (as the title of your question stated), so maybe I missed something.

    % This is test.tex
    \documentclass{article}
    \usepackage{nomencl}

    \makeatletter
    \def\thenomenclature{%
      \@ifundefined{chapter}%
      {
        \section*{\nomname}
        \if@intoc\addcontentsline{toc}{section}{\nomname}\fi%
      }%
      {
        \chapter*{\nomname}
        \if@intoc\addcontentsline{toc}{chapter}{\nomname}\fi%
      }%

      \nompreamble
      \list{}{%
        \labelwidth\nom@tempdim
        \leftmargin=0pt
        \itemindent=\dimexpr\itemsep+\labelwidth\relax
        \itemsep\nomitemsep
        \let\makelabel\nomlabel}}
    \makeatother

    \makenomenclature

    \begin{document}
    Some text \nomenclature{LONG}{This is a long long long long long long
      long long long long long long long long long long long long long
      long long long long long long long long long long long long long
      long long long long long long long long long long long long long
      long long long text}

    \printnomenclature

    \end{document}
share|improve this answer
    
I'm sorry maybe I explained it wrong. –  lucacerone Nov 1 '11 at 21:39
    
@LucaCerone Maybe. But does my answer fit to your needs? –  cjorssen Nov 1 '11 at 22:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.