Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to install multi markdown LaTeX support so I can use MathJax in my markdown, but I can't find the texmf folder on my mac. More specifically, when I run kpsewhich I get ~/Library/texmf, but then when I try to access the folder through the Finder or Dock it won't show up.

I tried running mktexlsr, but I got

mktexlsr: /Users/jeff/Library/texmf: not a directory, skipping.
mktexlsr: /usr/local/texlive/2011/../texmf-local: directory not writable. Skipping...
mktexlsr: /usr/local/texlive/2011/texmf: directory not writable. Skipping...
mktexlsr: /usr/local/texlive/2011/texmf-config: directory not writable. Skipping...
mktexlsr: /usr/local/texlive/2011/texmf-dist: directory not writable. Skipping...
mktexlsr: /usr/local/texlive/2011/texmf-var: directory not writable. Skipping...
mktexlsr: Done.

Any idea what's going on?

share|improve this question
1  
as far as I know you need to run mktexlsr as superuser for it to work on /usr/... since a normal user can't write on those by default. Furthermore it looks like the texmf directory in your Library doesn't exist. You can simply create it. Of course there won't be anything in there, you can use it to install packages for only the current user, for instance. –  Roelof Spijker Nov 1 '11 at 9:46
    
From my reading of github.com/fletcher/peg-multimarkdown/wiki/…, you don't actually need LaTeX installed if you want to use MultiMarkdown to produce something suitable for MathJaX. –  Loop Space Nov 1 '11 at 10:00

2 Answers 2

This answer only deals with part of your problem.

You are probably using OSX Lion. In the new system the ~/Library folder is hidden by default.

You can change this permanently by issuing the following command:

chflags nohidden ~/Library

Or you can make it available each time you need it. To do this, when in the Finder, go to the Go menu (my system is French and the menu is "Aller") while pressing the Option key; the Library folder will be available.

share|improve this answer
    
@Alan : thanks for the edit, it is now a complete answer. –  Frédéric Dec 8 '11 at 14:09

I never used MathJax, but the messages above indicate that you don't have write rights to the directories.

Execute the command as root.

share|improve this answer
    
Which on OSX means to use sudo from an admin account. (root is generally never enabled as an account in OS X). –  Alan Munn Dec 7 '11 at 19:44
    
But as @Frédéric says in his answer, the issue here is likely related to the fact the jefflovejapan is using Lion and the folder is made to be hidden by default. So mktexlsr won't help here. –  Alan Munn Dec 8 '11 at 1:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.