Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

I am working on writing a scientific poster in LaTeX, and I want to include a few references for my work. Because this is a poster, I have my own customized headers for different sections, and don't want my related works to have a separate title. Essentially I have something like this:

\begin{textblock}{5.5}(19.5,11)
\CHead{Related Work} %a newcommand header I wrote
\bibliographystyle{acm}
\bibliography{mybib}
\end{textblock}

And it comes out with a header called "Related Work" like I want, but it also under that says "References", which I don't want.

I found a few websites that said that I could override this with something like

\renewcommand\refname{}

But all this does is take the word "References" out, but the space allotted for the title is still there. Is there a way to completely eliminate the title and any space it may take up?

share|improve this question
1  
Good answer here: tex.stackexchange.com/a/22654/7825 –  SabreWolfy Aug 7 '12 at 19:38
add comment

migrated from stackoverflow.com Nov 1 '11 at 14:44

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Andrew Swann, Herbert, Alan Munn, mafp, Thorsten May 12 '13 at 14:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers

\renewcommand{\refname}{} just redefines the \refname (that is, the title of your related work section) to be blank. I believe you want to redefine the title of your related work section to be \CHead{Related Work}.

So, I would try writing \renewcommand{\refname}{\CHead{Related Work}} instead of manually inserting \CHead{Related Work} before the bibliography.

share|improve this answer
    
Good suggestion, but it formats things differently because I guess it wants to conform to what it thinks the bibliography header should look like. –  Bryan Ward Mar 12 '10 at 3:37
    
In what way(s) does the format not match what you want? It does get printed larger because BibTeX treats it as a section heading, but there are still things you can do to manipulate its appearance. For instance, I tested this solution by putting \renewcommand{\refname}{\center This is {\small my} {\em custom} name} into the heading of one of my LaTeX documents, and it did appear centered with small "my" and italicized "custom", as expected. So, you still may be able to tweak the appearance of the custom heading, depending on what exactly is not right about it. –  Joe Carnahan Mar 12 '10 at 3:56
add comment

I did a

\renewcommand\refname{\vskip -1cm}
\section{References}
\bibliographystyle{abbrv}
\bibliography{report}
share|improve this answer
add comment
up vote 2 down vote accepted

What wound up working best for me was to use \renewcommand\refname{} and then use negative vspace like so:

\begin{textblock}{5.5}(19.5,11)
\CHead{Related Work} %a newcommand header I wrote
\vspace*{-4cm}
\bibliographystyle{acm}
\bibliography{mybib}
\end{textblock}
share|improve this answer
add comment

I used \fancyhead{} before I set my custom fancyheader options and my problem was solved. I'm not sure if it will remove the space allotted for the header.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.