TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I usually prefer PDF images for my LaTeX documents because they are easy to crop/resize using Adobe professional. I am facing a weird problem. I modified one of the PDF images using Adobe professional by writing come comments using the pencil tool and added a rectangular box on the image and saved it. The LaTeX output is not showing the modification that I made to the image file but when i open the image file the modifications are still there. Did anyone face similar problems?

share|improve this question
Are the comments perhaps annotations? Or, elaborate more on how you added the "comments" to the existing PDF. – Werner Nov 2 '11 at 5:43
Yes, PDF annotations (notes, hyperlinks, etc.) will be lost in included PDFs. See the accepted answer to How to preserve hyperlinks in included pdf?. – Martin Scharrer Nov 2 '11 at 6:47
I found a quick and dirty way to do this. The original pdf image can be opened and edited in image editing softwares such as Corel Draw and saved back to pdf. Output image quality is excellent and it will retain all the modifications. This won't work for hyperlinks though. – John Smith Nov 4 '11 at 5:04
I also can recommend the free PDF annotator xournal. It saves back to PDF without rasterising. You should definitely pay attention that you don't rasterize your PDF. – Marco Nov 7 '11 at 23:12
Maybe you could post your solution in the form of an answer so that this question can be marked so (you can answer your own questions and accept them as well) :) – mpr Nov 13 '11 at 6:41

One way to do this preserving the vector form would be to use the Adobe Acrobat "Preflight" tool, which allows you to "flatten" your comments ("Flatten forms and annotations"). I tried to show you an example, but it comes reversed! Maybe it's a bug of version X. :(

Another way inside Acrobat it's to open a console (Ctrl-J) and then execute the command flattenPages() which I can confirm it's working in my version of Acrobat and it's correctly compiled in vector form by pdfLaTeX. The output is like this.

A third option to selectively flatten your content would be one of the several scripts of the Adobe Exchange like this one (there's plenty of others) in case that

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.