Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the package mathtools using the option showonlyrefs. This works fine, however some equation numbers are skipped. If I understood the manual correctly I need to load empheq to fix this. This works!

The problem now is that without empheq \allowdisplaybreaks works fine, but the equation numbering goes wrong, but with empheq the \allowdisplaybreaks seems to stop working (this is a command from amsmath).

Is this a common problem? I can't seem to find anything about it. How can I solve this?

Edit: I have finally found the time to make a MWE. See below.

\documentclass[a4paper,10pt, leqno, final, twoside]{scrbook}
\usepackage{amsmath}
\usepackage[overload, ntheorem]{empheq}
\usepackage[amsmath, thmmarks]{ntheorem}
\allowdisplaybreaks[4]
\usepackage{mathtools}
\mathtoolsset{showonlyrefs}
\mathtoolsset{showonlyrefs,showmanualtags}
\newtagform{brackets}{[}{]}
\usetagform{brackets}
\usepackage{blindtext}

\begin{document}

\blindtext[3]
\begin{align}
  A &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A\\
  &= A
\end{align}

\end{document}
share|improve this question
3  
Could you add a minimal working example (MWE) that illustrates the problem? –  Karl Ove Hufthammer Nov 2 '11 at 16:03
    
I tried with a simple document, with no problem. –  egreg Nov 2 '11 at 16:49
    
Okay, then I will add a MWE soon. –  Jonas Teuwen Nov 2 '11 at 16:58

1 Answer 1

Drop the overload option for the empheq package. You then can't use the short form for emphasized equations. See Section 2.2.2 of the package manual.

share|improve this answer
    
Thanks. That does fix a lot. However, now for some reason \tag[$\ast$] stopped working. Could this be connected to this? –  Jonas Teuwen Nov 10 '11 at 10:47
    
Shouldn't that read \tag{$\ast$}? –  Thorsten Donig Nov 10 '11 at 10:55
    
Yes, that's correct. –  Jonas Teuwen Nov 10 '11 at 11:44
    
I have no problem with manual tagging. –  Thorsten Donig Nov 10 '11 at 11:50
    
It is a strange thing, sometimes \tag{$\ast$} doesn't work, sometimes it does and when it doesn't \tag{*} does work. I'll try to figure out. –  Jonas Teuwen Nov 10 '11 at 11:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.