Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The problem:

How to fix bad boxes done by bibtex? Latex copy and paste bibtex formatted entries to the text, but these entries exceed the correct space.

Details: I using main.tex with this header:

\documentclass[a4paper,12pt,fleqn,oneside,openright]{book}

with this content at the end of it:

\addcontentsline{toc}{chapter}{Referências Bibliográficas}
\bibliographystyle{apalike}
\bibliography{12.Referencias_Bibliograficas}

I had too this bibtex entry:

@BOOK{chenpatton:99,
  AUTHOR =       "J. Chen and R. J. Patton",
  TITLE =        "Robust model-based fault diagnosis for dynamic systems",
  PUBLISHER =    "Dordrecht:   Kluwer Academic Publishers",
  YEAR =         "1999"

}

and finally this phrase:

A literatura apresenta muitas classes de estratégias para tratar o problema de FDI \cite{chenpatton:99}.
Estas estratégias podem ser, em geral, classificadas em abordagens baseadas em modelos quantitativos ~\cite{VR:03I} ~\cite{VR:03III} e em modelos qualitativos \cite{VR:03II} \cite{VR:03III}. Esta classificação é ilustrada na Figura~\ref{benchmark_1}.

My problem is, after the compilation I have this badbox

Overfull

and I don't know how to fix it.

See if I put a ~ before this cite looks like nothing happens and I have the same badbox. If I put a \\ I lose the justified text

Overfull2

How can I solve this?

share|improve this question
    
The information is insufficient; how do you load natbib? –  egreg Nov 7 '11 at 20:25
    
Are you talking about the packages \usepackage[round]{natbib} \usepackage{natbib} ? If yes, they're disabled in my document, need them? –  GarouDan Nov 7 '11 at 20:27
    
I had enable these packages but it takes the brackets [] and I need them. My bibtex runs the following command: >bibtex 12.Referencias_Bibliograficas.bib –  GarouDan Nov 7 '11 at 20:35
    
I have some other problems like these in the document so I think it's better solve it instead just change the text. –  GarouDan Nov 7 '11 at 21:01
3  
If you say \usepackage[square,authoryear]{natbib} and then use \citep instead of \cite, you get correct breaking. –  egreg Nov 7 '11 at 21:09
show 1 more comment

2 Answers

up vote 5 down vote accepted

We almost had a diplomatic crisis between Italy and Brazil, so per peer pressure, I'm writing down this answer. :)

egreg and I came to the same solution, so here it is.

  1. Use \usepackage[square, authoryear]{natbib} instead of \usepackage[round]{natbib}. The package options mean:

    • square: says that references are to be enclosed in square bracket rather than round parentheses.
    • authoryear: used for author–year citations.
  2. Use \citep instead of \cite. Please note that \citep is a natbib exclusive command. It is used for parenthetical citations.

Hopefully we get rid of the bad blocks that way. :)

share|improve this answer
    
Crisis? Lol...for me it's all ok =) You're welcome the see the World Cup here hehe –  GarouDan Nov 7 '11 at 21:41
add comment

Insert \linebreak where the line should end. Unlike \\, \linebreak will keep the line justified.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.