Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is my LaTex script:

\documentclass[a4paper]{article}
\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{xltxtra}
\setmainfont[Mapping=tex-text]{Jenson Classico}
\begin{document}
ąęśćłó
\end{document}

I compile this using xelatex through eclipse plugin.

As Jenson Classico has no polish characters I have edited this font to add them. In Microsoft Office it works fine (I am able to use polish characters). Unfortunately in pdf generated from above tex-file it doesn't. If I use any other font (e.g. Arial) it works like a dream.

Any suggesions? I really don't have any more ideas...


This is part of the log file:

Requested font "Jenson Classico" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf
Requested font "Jenson Classico/ICU" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf
 fontspec Info: Font Jenson Classico does not contain any OpenType `Script' inf
ormation.

\c@zf@famc@Jenson Classico=\count151
 fontspec Info: Defining font family for 'Jenson Classico' with options [Mappin
g=tex-text].

Package fontspec Info: Defining shape m/n with raw font features:
(fontspec)             mapping=tex-text;.
Requested font "Jenson Classico/B/ICU" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf
 fontspec Info: Could not resolve font Jenson Classico/B (it probably doesn't e
xist).

Requested font "Jenson Classico/I/ICU" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf
 fontspec Info: Could not resolve font Jenson Classico/I (it probably doesn't e
xist).

Requested font "Jenson Classico/BI/ICU" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf
 fontspec Info: Could not resolve font Jenson Classico/BI (it probably doesn't 
exist).

Requested font "Jenson Classico/ICU:mapping=tex-text;" at 10.0pt
 -> C:/WINNT/Fonts/Jenson.ttf

[...]

Missing character: There is no ą in font Jenson Classico/ICU:mapping=tex-text;
!
Missing character: There is no ę in font Jenson Classico/ICU:mapping=tex-text;
!
Missing character: There is no ś in font Jenson Classico/ICU:mapping=tex-text;
!
Missing character: There is no ć in font Jenson Classico/ICU:mapping=tex-text;
!
share|improve this question
    
Do you have multiple versions of the font installed, e.g., both with and without these characters? If so, be sure to remove the other one. –  frabjous Sep 23 '10 at 14:23
    
No. Folder C:\WINNT\Fonts contains only one file jenson.ttf –  Filip Sep 23 '10 at 14:26
    
Well xelatex can search other places too. Also you are calling the font by its internal name and there can be other fonts with this name. Put \XeTeXtracingfonts=1 in your document and call xelatex on the command line with the option --output-driver="xdvipdfmx -vv". This should show you in the log and on the terminal which fonts xetex + xdvipdfmx are actually using. –  Ulrike Fischer Sep 23 '10 at 14:36

1 Answer 1

What does the log file say? If XeTeX thinks the font is missing characters you'll get in the log file

Missing character: There is no ä in font [...]!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.