Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using aspell --version International Ispell Version 3.1.20 (but really Aspell 0.60.6) to verify my tex files with the command:

aspell -d pt_PT --dont-tex-check-comments  -c file0.tex

The problem is that ispell checks inside each

\citep{someone2011sometitle} 

and each

\citet{someone2011sometitle}

that I'm using with

\usepackage[authoryear]{natbib}

What can I do for ispell to ignore the references?

share|improve this question
    
Very old versions involved here => 'too localized'. –  Joseph Wright Nov 30 '11 at 12:56
add comment

2 Answers

up vote 10 down vote accepted

The manual says that you need to add the following to the command line:

--add-tex-command citep op --add-tex-command citet op

Here op means that each command (\citet or \citep) may have one optional parameter and has one mandatory parameter, and neither should be checked (if you want to check the optional one, use Op instead).

See http://aspell.net/0.50-doc/man-html/4_Customizing.html

Update: the proper syntax (for some versions of aspell?) might be

--add-tex-command="citep op" --add-tex-command="citet op"
share|improve this answer
2  
Thank you for the solution. I browsed the documentation but didn't figure out how to do this. Sill, in my system, I had to do --add-tex-command="citep op" (with the = sign and with quotes). –  Luis Nov 12 '11 at 22:39
    
I think the manual might be wrong here, and the ="..." is the right one... –  Boris Nov 12 '11 at 22:49
add comment

To add the setting to the configuration file (/etc/aspell.conf or ~/.aspell.conf), you don't need the quotes:

add-tex-command citep op
add-tex-command citet op
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.