Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm with a problem with the package epspdfconversion. I use the following preamble:

\documentclass[pdftex,12pt,a4paper,openany]{memoir}
\usepackage[brazil]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{indentfirst}
\usepackage{latexsym}
\usepackage{amsmath,amssymb,amsfonts,wasysym}
\usepackage{graphicx}
\usepackage[help]{epspdfconversion}
\usepackage[left=3cm,right=2cm,top=3cm,bottom=2cm]{geometry}
\usepackage[center]{caption}
\usepackage{color}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\usepackage[pdftex, colorlinks=true, linkcolor=black, citecolor=black, urlcolor=black]{hyperref} 
\usepackage[all]{hypcap}

and when I try to add a figure:

\begin{figure}
\includegraphics[scale=0.5]{ocupfd.eps}
\caption{a}
\end{figure}

the program gives me the following error:

Package pdftex.def Error: File `ocupfd-epspdf-to.pdf' not found

What should I do?

share|improve this question
1  
Are you calling pdflatex with the -shell-escape option? If you don't need any of the fancy options of epspdfconversion, maybe \usepackage{epstopdf} will do, without even the command line option, if your TeX distribution is recent. –  egreg Nov 14 '11 at 23:39
    
@egreg How do I execute this -shell-escapeoption? –  Rodrigo Thomas Nov 15 '11 at 0:24
    
It depends on your settings: operating system and editor. –  egreg Nov 15 '11 at 0:25
    
I use Ubuntu, and TeXMaker –  Rodrigo Thomas Nov 15 '11 at 0:27
    
@egreg Could you tell me how do I execute the -shell-escapeoption for the TeXMaker on Ubuntu? –  Rodrigo Thomas Nov 15 '11 at 1:21

1 Answer 1

up vote 7 down vote accepted

The epspdfconversion package needs that pdflatex is called with the command line option -shell-escape. How this is done depends much on what is the TeX environment one uses.

For example, with Texmaker (or TeXStudio) it's sufficient to go to the configuration window and add the option in the PdfLaTeX tab so that it looks like

pdflatex -interaction=nonstopmode -shell-escape %.tex

Similarly for other TeX editors.

The package offers many fancy options. If one doesn't need them and has TeX Live 2010 or later (or MiKTeX 2.9), it's easier to load the package epstopdf and the conversion will be done automatically, without the need of the -shell-escape option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.