Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using beamer with the wkbeamer theme in Emacs and I can't figure out how to get it to not output in presentation mode, which is quite annoying when creating the document. Every time I view it the flag is set to automatically launch in presentation mode. Does anyone have experience in this matter or no where I can change the beamer settings for this? Or if this is possibly located in the wkbeamer theme?

share|improve this question
    
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. –  Martin Scharrer Nov 15 '11 at 15:02
    
With "presentation mode" you mean fullscreen in the PDF viewer? There is actually a presentation mode in beamer which the normal mode. There is a handout mode to produce handouts etc. The fullscreen mode setting is a hyperref setting. Have a look at its manual. –  Martin Scharrer Nov 15 '11 at 15:07
    
@MartinScharrer - Nope I meant as you answered below but still was wondering whether that overwrites the other previous set variables or just resets the one. –  J Spen Nov 16 '11 at 1:23
add comment

migrated from stackoverflow.com Nov 15 '11 at 14:53

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 5 down vote accepted

It is set in beamerthemewkbeamer.sty (the main wkbeamer theme file) using:

\hypersetup{pdfpagemode={FullScreen}, ...}

You should be able to change that setting after loading the theme with:

\hypersetup{pdfpagemode={UseNone}

If this doesn't work (some options are only valid the first time they are used), place that line before you load the theme.

Search the hyperref manual for pdfpagemode to get more details.

share|improve this answer
    
I had sorted that was the culprit and removed it from wkbeamer but that's even better. I'll put it back and it works just putting it below the loading of the theme. Will it overwrite the other settings like linkcolor, etc,... set for hyperref in the wkbeamer or just overwrites that one setting. –  J Spen Nov 16 '11 at 1:21
    
No, it will only overwrite the pdfpagemode setting. –  Martin Scharrer Nov 16 '11 at 7:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.