Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
\documentclass{article}
\usepackage{lipsum}
\usepackage[doublespacing]{setspace}
%\usepackage[onehalfspacing]{setspace}
\setlength{\parskip}{0pt}
\usepackage[b5paper]{geometry}
\begin{document}
{\footnotesize\lipsum[3]\lipsum[3]}
text\footnote{\lipsum[3]}
text\footnote{\lipsum[3]}
\end{document}

If I use setspace package to change the line spacing, you can see that there is a big space between the two footnotes. How do I make the footnote just like the main body, as if it were like two paragraphs?

share|improve this question
    
For clarity, there is another code: \documentclass{article} \setlength{\parskip}{0pt} \usepackage{lipsum} \usepackage[b5paper]{geometry} \linespread{2} \begin{document} {\footnotesize\lipsum[3]\lipsum[3]} text\footnote{abc abc abc abc abc\par abc abc abc abc abc abc} text\footnote{abc abc abc abc abc\par abc abc abc abc abc abc} \end{document} –  Tau spit Nov 16 '11 at 14:44
1  
You can actually edit your question and add your additional code there, so it'll be easier to read. –  doncherry Nov 16 '11 at 15:26

1 Answer 1

up vote 10 down vote accepted

The space between two footnotes is stored in \footnotesep. Change that to zero and voilà:

\documentclass{article}
\usepackage{lipsum}
\usepackage[doublespacing]{setspace}
        % setspace is irrelevant to this problem, but I didn't comment
        % it out to demonstrate that it doesn't influence the footnotes.
%\usepackage[onehalfspacing]{setspace}
%\setlength{\parskip}{0pt}
%\usepackage[b5paper]{geometry}

\setlength{\footnotesep}{0pt}% <---

\begin{document}
%{\footnotesize\lipsum[3]\lipsum[3]}
text\footnote{\lipsum*[3]}
text\footnote{\lipsum*[3]}
\end{document}

And here's the bottom part of the output:

footnotes without space in between

I changed the \lipsum[3] footnote paragraphs to \lipsum*[3] because the unstarred version adds a \par at the end of the paragraphs, which leads to undesired empty lines. The starred version doesn't add the \par. [Thanks to egreg for explaining!]

I commented out some parts of your MWE that aren't relevant to this problem. It is neither influenced by setspace (which doesn't change the line spacing of footnotes) nor by the paper size. The line \setlength{\parskip}{0pt} does hardly anything in a standard document because its standard value is 0.0pt plus 1.0pt, which means there might be a one point space between paragraphs if it's really necessary in order for the entire page to look good. Unless you know why you want to change this, it's recommendable to keep the standard setting.

share|improve this answer
3  
It doesn't work because each "lipsum" paragraph is terminated by \par. Using \footnote{\lipsum*[1]} won't give the extra line. –  egreg Nov 16 '11 at 15:46
    
I was expecting something along those lines, thanks for clarifying. –  doncherry Nov 16 '11 at 15:47
2  
I forgot to say that \footnote adds a \strut at the very end of the footnote text; if it is \lipsum[1], we'll have, at the end, \par\strut which forces an extra paragraph. –  egreg Nov 16 '11 at 15:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.