Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem with Biblatex Authortitle. I am trying to define the shorthand field connected with the style. the program I use (Citavi) creates the shorthands such as Gozzoli The Writing of History. Whenever I use the style however, the title appears without italics and comma between name of the author and title. My ideas for the citation was of having the author surname in Small Capitals, then comma, then the title of a book in italics and the title of an article in double quotation marks for instance. For the bibliography, the actual style was OK, at least for the moment. I have scanned through the Biblatex manual, but I have not found a way to do that, and a Google search did not help either. I am an Egyptologist trying to use XeLateX in the field, so please excuse me whether the question is slightly banal.

As required I am now adding the example, the text is only garbage:

\documentclass[11pt]{memoir} % for a long document
\usepackage{filecontents}
\begin{filecontents}{PsammetichusII.bib}
@article{Gozzoli.2000,
author = {Gozzoli, Roberto B.},
year = {2000},
title = {The Statue BM EA 37891 and the Erasures of Necho II's Names},
pages = {67–80},
paginationtype = {page},
volume = {86},
journaltitle = {JEA},
shorthand = {Gozzoli The Statue BM EA 37891},
usera = {Yes},
userb = {Statue BM EA 37891}
}


@book{Gozzoli.2006b,
author = {Gozzoli, Roberto B.},
year = {2006},
title = {The Writing of History in Ancient Egypt during the First Millennium BC(ca.   1070-180 BC). Trends and Perspectives},
volume = {6},
publisher = {Golden House Publications},
shorthand = {Gozzoli The Writing of History in},
location = {London},
series = {Golden House Studies},
usera = {Yes},
userb = {Writing of History in Ancient Egypt}
}


@article{Gozzoli.1995,
author = {Gozzoli, Roberto B.},
year = {1995},
title = {The Nubian War Texts of Psametichus II: An Essay of Explication},
pages = {46–49},
paginationtype = {page},
volume = {25},
journaltitle = {JSSEA},
shorthand = {Gozzoli The Nubian War Texts of},
usera = {Yes},
userb = {Nubian War Texts}
}


@article{Gozzoli.1997,
author = {Gozzoli, Roberto B.},
year = {1997},
title = {La campagna nubiana di Psammetico II e i testi di frontiera saitici},
pages = {5–16},
paginationtype = {page},
volume = {38},
journaltitle = {DE},
shorthand = {Gozzoli La campagna nubiana di Psammetico},
usera = {Yes},
userb = {La campagna nubiana}
}
\end{filecontents}

\usepackage[style=authortitle,backend=biber]{biblatex}
%\usepackage[style=footnote-dw,backend=biber]{biblatex}
\addbibresource{PsammetichusII.bib}

%%% BEGIN DOCUMENT
\begin{document}

reign.\footnote{\textcite{Gozzoli.1995,Gozzoli.1997,Gozzoli.2000}The two articles     about    the Nubian texts, originally treated in the     dissertation,\Parencite{Gozzoli.2006b,Gozzoli.1995}
The second part is a list of royal documents or documents dated to Psammetichus II's     reign.\footnote{\autocite{Gozzoli.1995,Gozzoli.2006b}.}
share|improve this question
1  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  N.N. Nov 18 '11 at 6:32
    
This is the example for it: –  Roberto Gozzoli Nov 18 '11 at 6:37
    
Please include the MWE in your question by editing it. –  N.N. Nov 18 '11 at 6:38
1  
A tip for cases such as these is to use the filecontents package and environment in the preamble, as I did in my edit. This will write the contents of the environment to the filename specified as the argument, and saves us from copying the bib-info to a new file. –  Torbjørn T. Nov 18 '11 at 9:19

1 Answer 1

Well, the problem is that Citavi produces the shorthand fields which override the ‘normal’ citation behaviour of the biblatex style. So, the best solution would be to tell Citavi not to use automated shorthands. If you need a shorter title you should use the shorttitle field. I am not too familiar with Citavi, but, as far as I know, biblatex support was added recently. Thus, the export should be customizable, and hence it should be possible to omit the shorthand field in the export. If not, I would consider this a Citavi bug. Anyhow, I would ask for support in this case at the Citavi support forum (which has both a German and English part).

Edit: Now that I understand your problem better, I can give a minimal example for your desired output. As already said, use shorttitle instead of shorthand and omit the name (just give a short form of the title). The names in small caps can be achieved through \renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}.

\documentclass[11pt]{memoir}
\usepackage{filecontents}
\begin{filecontents}{PsammetichusII.bib}
@article{Gozzoli.2000,
author = {Gozzoli, Roberto B.},
year = {2000},
title = {The Statue BM EA 37891 and the Erasures of Necho II's Names},
pages = {67--80},
paginationtype = {page},
volume = {86},
journaltitle = {JEA},
shorttitle = {The Statue BM EA 37891}
}
@book{Gozzoli.2006b,
author = {Gozzoli, Roberto B.},
year = {2006},
title = {The Writing of History in Ancient Egypt during the First Millennium BC (ca.   1070-180 BC). Trends and Perspectives},
volume = {6},
publisher = {Golden House Publications},
shorttitle = {The Writing of History in},
location = {London},
series = {Golden House Studies}
}
@article{Gozzoli.1995,
author = {Gozzoli, Roberto B.},
year = {1995},
title = {The Nubian War Texts of Psametichus II: An Essay of Explication},
pages = {46--49},
paginationtype = {page},
volume = {25},
journaltitle = {JSSEA},
shorttitle = {The Nubian War Texts of}
}
@article{Gozzoli.1997,
author = {Gozzoli, Roberto B.},
year = {1997},
title = {La campagna nubiana di Psammetico II e i testi di frontiera saitici},
pages = {5--16},
paginationtype = {page},
volume = {38},
journaltitle = {DE},
shorttitle = {La campagna nubiana di Psammetico}
}
\end{filecontents}

\usepackage[style=authortitle,backend=biber]{biblatex}
%\usepackage[style=footnote-dw,namefont=smallcaps,backend=biber]{biblatex}
\addbibresource{PsammetichusII.bib}

\renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}

\begin{document}

\textcite{Gozzoli.1995,Gozzoli.1997,Gozzoli.2000} 

\parencite{Gozzoli.2006b,Gozzoli.1995}

\autocite{Gozzoli.1995,Gozzoli.2006b}

\end{document}

By the way, if you use footnote-dw (or authortitle-dw), the names in small caps can be achieved through the package option namefont=smallcaps. See the biblatex-dw package documentation for details.

share|improve this answer
    
For Torbjørn, I thank you for the precisation. I did not know about the filecontents package, so I apologise. For domwass, I have understood the problem after your help. I have already created and export file that does automatically use shorthand, and I have created a shortitle field for that. I believe creating small capitals for name will require some macros and encoding, which I may not be able to do it. So I am happy as it is at the moment. –  Roberto Gozzoli Nov 18 '11 at 14:11
1  
@RobertoGozzoli, I would suggest to leave out the name in your shorttitle field in Citavi and export it to shorttitle rather than to shorthand. The authortitle style will then take the author and the shorttitle. In order to get the names in small caps, you can use \renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}. –  domwass Nov 18 '11 at 14:51
    
thanks for the suggestion. As I wrote down the comment, I made a mistake. I have actually deleted shorthand, and just put a very short title for shorttitle. Also the small capitals renew command is working fine. –  Roberto Gozzoli Nov 18 '11 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.