Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have my project configured in Texlipse to create an index and I am issuing the \printindex command towards the bottom of my root TEX file. I have my files organized in a tree structure as indicated in my question here. When the project builds, the IDX file is properly generated and contains the terms I have placed in the index. The tool places the file however not in the intermediate folder but in the same folder where my root TEX file resides. I could live with that but, unfortunately, no index appears in the compiled document. Is this possibly a bug in Texlipse or do I need to do something else in order to include the index in my output document?

share|improve this question
    
Do you (or TeXlipse, automatically) run makeindex on the .idx file? –  Torbjørn T. Nov 18 '11 at 15:29
    
@TorbjørnT. I don't run it manually; I assume that TeXlipse is supposed to do that. It has an option for "Make Index Style File" in the project properties that I have set to "texfiles/makeidx.sty" which lives in my project but other than that I don't see any other makeindex options other than the path to the EXE which I have specified in my environment settings. –  3Sphere Nov 18 '11 at 15:38
    
Well, I'm not familiar with TeXlipse, so I'm afraid I cannot help. –  Torbjørn T. Nov 18 '11 at 15:50
    
Does TeXlipse do the required multiple runs? If you are not sure, remove the index file, run it once to make sure it generated the index file, then leave all the auxiliary files, and rerun. –  Peter Grill Nov 27 '11 at 1:42

2 Answers 2

The makeindex problem in TeXlipse is well-known. I guess that it is a bug in TeXlipse.

I found a solution in my environment: Clean your project, here is important that no output.pdf file exits after that! Than build it again, for some unknown reasons now I have a index in my new pdf.

Another solution is to replace the pdflatex.exe in your build settings with an batch-script witch calls pdflatex - makeindex - pdflatex. There you can control witch files are used but of course it is not the right way to bypass TeXlipse here.

EDIT

I found another nice way to run additional programs during the build process in this Question: http://tex.stackexchange.com/a/52549/11363

You can use it to run a makeindex manually for several conditions.

share|improve this answer
    
solution 1 does not work for me. for solution 2, how do you replace pdflatex with a batch script in TeXlipse? –  pegausbupt Sep 3 '12 at 13:31
    
You can find the Texlipse Builder Settings in the Eclipse Prefereces. There you find a list of programs and can replace the "PdfLatex program" with the batch script by editing its program-path. –  Indimental Sep 6 '12 at 12:34

It's not clear where the .idx file is created. When xelatex is called with the option

xelatex -output-dir=./subdir file

then the .idx file is created inside subdir.

You should configure the call to MakeIndex to look for the file inside subdir:

makeindex -s mystyle.ist -o ./subdir/filename.ind -t ./subdir1/filename.ilg ./subdir/filename
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.