Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing a letter in LyX, and I want to choose a document class for it. (I don't like the default letter.)

Looking at Document -> Settings -> Document class, I see that most classes are "unavailable". For example, Unavailable: Letter (KOMA-script). How do I make those available?

I tried installing the koma-script package in the MiKTeX package manager, but it didn't help.

EDIT:

Here's the dialog I get when doing Reconfigure:


LyX: System reconfiguration failed

The system reconfiguration has failed. Default textclass is used but LyX may not be able to work properly.

Please reconfigure again if needed.

OK

share|improve this question
    
Go to tools and then choose reconfigure –  Herbert Nov 20 '11 at 19:02
    
Windows XP, LyX 1.6.7. (Don't know what "TeX distribution" means or how I find it out.) –  Ram Rachum Nov 20 '11 at 19:03
    
Did you refresh the file name database? (General tab in MikTeX options.) –  Torbjørn T. Nov 20 '11 at 19:04
    
It is okay you edited your answer with this details. Do the reconfigure and restart LyX –  Herbert Nov 20 '11 at 19:04
    
@Torbjörn: The package manager of MiKTeX does it by default –  Herbert Nov 20 '11 at 19:05
show 3 more comments

1 Answer

From the LyX Wiki, Trouble Configuring LyX (missing classes) with MikTeX:

MiKTeX can cause problems with the configure script in LyX if the "Install missing packages on-the-fly" option is checked. If you find that only a few classes are available in LyX under Windows, try disabling this option in the MiKTeX general options (mo.exe) and re-configuring LyX.

So start MiKTeX options (start menu or mo.exe) and choose No (rather not not "Ask me first") for the option "Install missing packages on-the-fly", as recommended in the MiKTeX 2.9 issues (actually for TeXnicCenter compatibility), valid also for MiKTeX 2.8. If necessary, install manually using the MiKTeX package manager, and reconfigure LyX.

Here's a screenshot of the options window:

MiKTeX options

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.