Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I generate my pdfs using MikTex 2.9 on Windows 7. On W7 everything looks good. On my other computer where I have CentOS release 5.2 (Final) installed I experience strange display on page numbers. On that computer I use Adobe Reader ver 9.4.2 02/11/2011. Images below are examples of how it looks like on Page Navigation toolbar:
(this should be page A)
(this should be page 3)

In my document I include 2-page pdf at a beginning (pages A and B). Next, there are tex-generated pages (pages 1 to 17). My input tex document is saved using Unicode encoding.

I know this might not be latex issue, but can I do something in it, so I don't get those glitches on CentOS version of Adobe Reader?

share|improve this question
    
did you run xelatex? –  Herbert Nov 21 '11 at 10:28
6  
For me it looks as if the page number are in unicode and the reader can't extract them correctly. If you are using hyperref you could try \usepackage[pdfencoding=auto]{hyperref}. –  Ulrike Fischer Nov 21 '11 at 10:42
    
@UlrikeFischer, your solution worked. You may add an answer so I can accept it and vote up :). –  Ichibann Nov 21 '11 at 19:48
    
@Herbert, I'm using pdflatex. –  Ichibann Nov 22 '11 at 7:30
    
@Ichibann: then follow Ulrikes advice ... –  Herbert Nov 22 '11 at 8:06

3 Answers 3

up vote 9 down vote accepted

For me it looks as if the page numbers are in unicode and the reader can't extract them correctly. If you are using hyperref you could try \usepackage[pdfencoding=auto]{hyperref}.

share|improve this answer

You’re probably using the hyperref package with the unicode option, e.g.:

\usepackage[unicode]{hyperref}

Just remove the unicode option, and everything will be fine. Note that you can still use UTF-8 as the input encoding.

share|improve this answer
    
You are right. I use hyperref with unicode option. I don't want to disable it. Is there other way? –  Ichibann Nov 21 '11 at 11:03
    
@Ichibann What is the reason you don’t want to disable it? –  Karl Ove Hufthammer Nov 21 '11 at 11:08
    
I want to keep Polish diacritics in pdf's bookmarks. –  Ichibann Nov 21 '11 at 11:13

This could be a font embedding issue. If you have access to the pdffonts tool on CentOS you can use it on your pdf to see which typefaces is uses versus which it has embedded. You can probably use Acrobat Viewer to do this too.

If it's missing some, then you can configure pdflatex (assuming you're using that) to embed them for you. I'm not sure about this on Windows, but on Linux the command is

updmap --edit

and it seems on Windows to be

initexmf --edit-config-file updmap

and then find pdftexDownloadBase14 and set it to true. Make sure to check the file to ensure that it doesn't get turned off again.

The next part is shamelessly pinched from an answer to the Stack Overflow question How do I embed fonts in an existing PDF?. Ghostscript can be used to reprocess the pdf to contain the fonts that are missing. This way you can repair existing pdf files that are causing you trouble.

gs \
  -sFONTPATH=/path/to/fonts:/another/dir/with/more/fonts \
  -o output-pdf-with-embedded-fonts.pdf \
  -sDEVICE=pdfwrite \
  -dPDFSETTINGS=/prepress \
   input-pdf-where-some-fonts-are-not-embedded.pdf
share|improve this answer
    
Please, see my edit. –  Ichibann Nov 21 '11 at 9:19
    
Try my solution, then see if it works. ;) –  qubyte Nov 21 '11 at 9:21
    
I've added a ghostscript command. This should allow you to repair pdf files that you have already generated that have this problem. –  qubyte Nov 21 '11 at 9:37
    
What font path is there on CentOS? –  Ichibann Nov 21 '11 at 9:55
    
chkfontpath --list should tell you where they are, but you may need to install that utility. Honestly, I know little about CentOS. –  qubyte Nov 21 '11 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.