Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the following reference:

V.L. Ginzburg and L.D. Landau, Zh. Eksp. Teor. Fiz. 20 (1950) 1064

which was translated in:

L. D. Landau, Collected papers (Oxford: Pergamon Press, 1965) 546

Is there a good way to make an (one?) entry in a bib(la)tex file that gives something similar to:

V.L. Ginzburg and L.D. Landau, Zh. Eksp. Teor. Fiz. 20 (1950) 1064; English translation: L. D. Landau, Collected papers (Oxford: Pergamon Press, 1965) 546

There is a translator field in biblatex, but it is not enough, since year, magazine etc. are different, too.

My solution so far is \cite[][English translation: L. D. Landau, Collected papers (Oxford: Pergamon Press, 1965) 546]{citekeyoriginal}. Is there a better way? I am using the numeric-comp biblatex style.

share|improve this question
    
We'll need to know which biblatex style you use. –  Joseph Wright Nov 21 '11 at 13:27
    
I use the numeric-comp style. –  Andy Nov 21 '11 at 13:31

1 Answer 1

up vote 6 down vote accepted

I am not able to provide a perfect solution, but I would use a \fullcite in the addendum field. In order to suppress the translation in the bibliography (so that it does not appear twice), you could use options = {skipbib=true}, if that is desired. Here is a MWE (note that you have to run biber (or BibTeX) twice, since the \fullcite can only be resolved in the second run):

\documentclass[english]{scrartcl}
\listfiles
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{G-L1950,
  author = {Ginzburg, V. L. and Landau, L. D.},
  title = {A title},
  journaltitle = {Zh. Eksp. Teor. Fiz.},
  date = {1950},
  volume = {20},
  pages = {1064},
  addendum = {English translation: \fullcite[546]{L1965}}
}
@book{L1965,
  author = {Landau, L. D.},
  title = {Collected Papers},
  location = {Oxford},
  publisher = {Pergamon Press},
  date = {1965},
  options = {skipbib=true}
}
\end{filecontents}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage{babel,csquotes}

\usepackage[
  style=numeric-comp,
  backend=biber
]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\cite{G-L1950}

\printbibliography
\end{document}
share|improve this answer
    
I would indeed call it the perfect solution (for me :) –  Andy Nov 21 '11 at 16:24
    
Really great solution! +1 –  AndreasT Aug 23 '13 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.